Using Path Light Node to hide background image to the camera

Hello,

It’s probably as ancient trick as a famous silk road. I have background image which I am currently testing for my scene. In the first instance I have this node set up without Light Path node to make my background image transparent in which I use emission node to control background image brightness . It works :


In the second node set up I use Light Path (shadows ray) and my background comes out a little too washed out for my taste. So I try to crank the brightness by hooking up curves node but no matter what I do with curves it doesn’t effect background image in render:


What do I miss?

Thanks
T

Is this a Background or image on a plane?
If it is a background import the image into an Environment Texture Node if an image on a plane then as a standard Image Texture…

I do use “image as plane” for both node set ups. Do you mean set it up as a simple plane and hook up "image texture " to it ? If so i’ve tried it. Brightness has no control whatsoever.

Is that your Window? I ask because you are sending it through a transparency node…

I find that the image comes out way too dark and has to be bumped up…but that is just the image…stop it from casting a shadow…turn off shadows in the material setting way down at the bottom under Viewport display ( for cycles ) Eevee under AlphaBlend Mode

1 Like

Actually glass from windows have been removed. I should have mentioned in the post though. I guess settings are different then in the node group and in material settings right?

Not by that much…
I see now what you are doing… and would advise that you add an emissive node to the mix…and bring it in as Image as a Plane…as long as you are not adding glass the Light path node isn’t needed…here is a quick one using cycles…you would need to tweak it a bit for EeVee…

Same arrangement except plugged into the emissive…Light path Node and really the transparency node aren’t needed…and could lead to problems…and this needs to be set up for one specific window shot…

-I just re-read your topic and have screwed up…thinking you were after something totaly different…-

This is what I use when rendering and want to hide my Background images but still get the lighting…I use an HDRI in the world settings… and set up my nodes like this…

First with Light path disconnected…

and second with it connected…

Is this what you were looking for???

1 Like

Sorry for such late reply although I was always looking forward to come back to you as I am very eager to sort this one out for the future projects. Sadly it doesn’t work yet as anything in the window is white.

You got it the idea right from the first time. When and if I need to hide HDRI background I just switch it to “transparency” in settings. I don’t know how else I can explain it. Anyway, yuor dusk scene is exactly what I try to achieve.

Just for the record do you want to try and use sky texture to see if that works ? I am suing sky texture as a light source.

Many thanks for sticking with me :wink:

Ok…If you are using a Sky-Texture for the world settings and adding the Image Background for your window view…the Sky-Texture is more than likely Blowing out your Image Background…
You will have to drop down the World Strength to something like .8 or even further…that will still get you lighting for the world and you can then increase the transparency of the Image Background and maybe just a bit more emissive and use the RGB Curves or Brightness etc… to enhance the image…
It will be a fine line between them…make sure that the Background image cast no shadow…
Tweaked to fit Sun on a Nashita Sky to match + -, to the image background…

1 Like

I wonder why you unplugging Light Path node? Without I can’t see no image plane. However if I plug the node (Lightpath) I see the forest.
Now if I reduce Sky texture intensity my room severely suffer from a lack of light. At this point I see you helping me a lot but maybe maybe something is not right in my settings …I miss something?

Would you be willing to take a look at my room scene? Of course if that’s much of me to ask. If not I understand. I can PM you with link to file.

Many thanks!

Sure it may be easier for me to understand what you are doing and where the problems are…just as long as the file isn’t several hundred meg :wink:

1 Like

Hooray! Let me trim the file and I shall come back to you in a day or two :wink:

1 Like

OK…

  1. On your image as a plane…you don’t need the transparency or the light path…they really serve no purpose…the only thing you need in the nodes for this are these…


your color RGB Curves can now control the Bright-Dark of the background image plane…
and set this in the viewport settings…
image

  1. Now to the world settings…If you want to use a sky texture as well as an HDRI, that is where you can use the Lightpath Node which helps with the shadows inside of the room…
    it also helps to turn on AO in the world settings…

Now then that should get you to where you want to be…and now for the kicker…the reason you couldn’t darken the background image and it was blown out! The specular was the problem…as well as having a semi-glossy roughness…turn OFF specular and kick up the roughness… :wink:

I didn’t see it till looking at your file… :thinking:

1 Like

Hey RSEhlers,

First of all many thanks for taking time and effort finding the ways to tackle the problem.

That method using Nishita Sky (light) + HDRI (image only) which worked very well for me. It is quiet convenient for the different camera angles because I don’t have to adjust “image as plane” to suit the angle. Now coming back to the “image as plane” actual method you suggest is fine and suits my needs almost :slight_smile: I know “almost” means almost. The thing is it still casts a slight shadow to my scene. If I have to I can find workaround by simply adjusting it in photoshop but it defeats the purpose sorting it out in the first place. I was wondering if you noticed it or it simply didn’t bother you?

:v: :+1:

Do you mean on that left wall two triangular shadows?
I think ( maybe wrong? ) but even hiding the forest plane from camera view and everything else in the scene but the room and window you still get those several shadows on the wall, and it looks like it might be light leaks from the top wall edges as they are miss-aligned with the crown molding sticking through here and there…

Yep…I just went in and dissolved a few of the wall edges and it deletes several of those lines…


Not sure where the line is now coming from…checked the lighting and it is most definitely a geometry problem…

Might be better to just redo the walls and make sure that they are sealed tight…

I added in a Backdrop Curtain UV’ed to the Forest texture just to check shadows. Works better than planes in most cases…I use them when I want details outside without adding in a bunch of geometry…

1 Like

Shadows they are meant to be because of the objects casting them. In fact I do prefer even some soft edgy shadows in the scene. I probably didn’t make myself clear enough. It’s the image plane that withholds light rays travelling through it and therefor it gets a little dimmer. Hope it makes sense. If you do render a) with image plane and b) no image plane you will see a little difference.

To be honest I did clean up geometry us much as I can although I might left some ends.
What and interesting idea to wrap the image plane. Will certainly try it out !

Just curious what do you normally use for the walls in terms of texture?

Thanks again!
T

Yes, very true…but by checking there are no objects in the scene that would cause those shadows…I even went in and hid everything from the camera and still get shadows that don’t conform to the lighting, it is like there is a light very low in the scene shinning light at an angle that is opposite to the scene lighting…though there isn’t one in the scene…

That’s what the emissive is there for to counteract that…

I use a noise texture plugged into a bump node with a very high scaling factor of 800++
and use a mix RGB to combine that with a Normal map if there is one…

Not sure why you get purple tint in the renders. Is it intentional? I have same scene ceiling sorted out there was 1 vertex lower than others. Now ceiling is flat with the walls. I also included some 3D objects in the middle of the frame in order to repeat shadows. Which shadows in your opinion do not conform to the light source?

P.S. Thanks for the wall texture tip.

Textures weren’t packed into the Blend file…( I went out and found a copy of the forest texture )…
It might have been that one vertex that was causing the shadows I see…
Of course, there is no texture so that makes a difference…


and our render settings more than likely are completely different, I just did a fast and dirty render…
Yours BTW turned out NICE!!

1 Like

It seems I didn’t enable “automatically pack resources”. I thought blender does it automatically. You know what I did on that wall (left) I simply deleted edges that serve no purpose. It worked for me. To be honest my geometry is a mess. Have to watch a few videos how to do it properly.

At this point I will thank you very much for sticking till the end with me. You saved me a few grey hair that’s for sure and I gained a lot of valuable skills :wink:

Best of luck to you :+1: :beers:

My pleasure!
Happy Blending my friend!:wink:

1 Like