Using planes for emitting light, but it reflects.

I am still quite a newbie at Blender, so I don’t know if there is a simple solution for this, or if it can be done.

I constantly run into situations where my lightsource reflects in the glossy materials that I have made. I know how to disable the plane that I use as lightsource from appearing on the render, however it still looks horrible when you can see a huge square of light in the reflection of the floor.

So my question is, is there a good way to disable the plane from reflecting in my materials, without disabling the actual light it emits?


you can uncheck “camera” from the visibility ray panel in that particular object’s properties.


In the object ray visibility options of the light emitting plane, de-select the glossy check box and your object will not be reflected in any glossy object.
In the same way that the camera check box removes the object from appearing to the camera, the glossy check box removes the object from appearing in glossy surfaces.

Hope this helps


Thanks a lot guys! It works perfectly!!

I have a similar problem - an object plane emitting light where the plane itself shows up as a bright white reflection on an object as the object flies in.

Is it possible to get the plane’s light effect on the object without the plane itself being reflected in the object? The texture is “car paint coated” which I’m afraid may be more than just glossy and that’s why the 2 suggestions don’t work.

Do I need to use a less complicated texture or is there a better solution 7 years after the originally posted question?

Hi @Vin_K, the textures are not relevant to the problem, the shaders (bsdf) are. (almost) Every bsdf has a corresponding ray type, which you can toggle from the object properties, or use in your shader graph for more precise control (using the light path node). What’s your car shader like (screenshots) ? and what effect do you want the plane to have on it exactly, if not a reflection ?

I need the plane’s light on the object, but without the white reflection of the plane.

When I render with all ray visibility settings turned off, the reflection is still there.

Looks like you’re changing the world settings. Is the reflection/light coming from that emissive plane? if so, disable the glossy ray visibility in its object properties.

Your examples clearly work. Not sure what’s wrong with mine and why the light pretty much goes away when I turn off glossy. Maybe mine has more glow from the object which contributes more light?

and turned off

Strange, can you share the file?

I tried to upload the file, but I’m too new here for it to trust me yet, I guess.

Here’s a link to a Google Drive zipped file:

You’re using a shader node group that apparently doesn’t include a diffuse component. Swap it for a diffuse/glossy mix and it’ll work

Thanks for all the effort. I’ve been messing with this off and on for weeks, but just ain’t familiar enough with Blender to get it to work.

Today I used a rectangular light and turned off Multiple importance in the Object data Properties and that seems to do enough of what I needed. NOt even remembering why I was using a plane for the light in the first place, but would still like to get that to work on my end so I have it for other object-shaped lights.

Wish I had more time to devote to Blender to take advantage of your help.

Now that Renderman for Blender is out I have to find time to get to that. Been a fan of that renderer for decades.

Thanks for all the help!