Using the right ctrl+alt+shift keyboard button on Linux


I am using blender on Manjaro Linux. Some keyboard shortcuts like ctrl+alt+shift+S doesn’t work in right part of the keyboard. I am a left handed that’s why I mostly use the right part of those keys.

Is there a way that I can make it work like the left ctrl+alt+shift?

Thank you.

Ahh a shortcut user (me too) and linux (Debian here)… it took my some time to notice that the icon/buttons (key T) sometimes are useful (not breaking fingers :wink: ) the second to last is shear with a nifty gizmo…

1 Like

shortcut makes production faster with Blender X Linux is much faster combination in production.

It’s just that there are times that I panic that my system is broken because when I use some hotkeys, (mostly alt+A on selecting loop) it doesn’t work on the right side but its fine in the other side.

Maybe there are some tweaks out there to make this work.

You do a search with something like this:"linux"+"swap"+"left"+"right"+"alt"

And you try with any of the results obtained, for example:

You also keep in mind that Alt Key may be being used by your Linux desktop, so you may have to do something like this:

1 Like

ah. so this is a Linux modification and not blender. I’ll try this one.

it just swaps. now the left alt became right alt. how can I make the right alt works just like the left alt and not just swap?

This is really a bug in Blender:

You must search in Ineternet about Linux workarounds until the bug is solved. You could subscribe to the previous report by commenting there your experience and informing there the OS you use and your keyboard layout/location that you use (Spanish, French, etc)
Also at the end of your message you ask there if you should open a new report to inform about the problem also occurs in Linux (because the previous report is labeled for Windows platform)

I find the solution here in this link.

I am Manjaro Linux KDE Plasma user and they have the option to fix this in the settings.

1 Like

Good to know that this workaround exists, I am also a KDE user.

Although apparently applying that workaround then it is not possible to use ALT in combination with others keys to write symbols (ALT+2 for @ for example)

1 Like