Using Victoria 4.2 - why so fugly?

Okay, so I’m very new to Blender and to 3D modelling in general. I would like to render Victoria in Blender for a psychology experiment I’m running. I also need to be able to scale down her poly-count. So, my first stab at doing this involved exporting her from Daz Studio as a Generic Collada file, and importing her into Blender 2.54. This is my result:

It sure is ugly compared to Daz Studio. I realize my lighting is pretty sub-standard right now, but that’s not my concern. I’m concerned with the model itself which looks to have some issues. There’s something definitely wrong with her eyes, both with the lashes and the eyeball itself. So my question is, why is this my result? Am I doing something wrong with the rendering process? Or the export/import process?

Any pointers would be much appreciated. :wink:

Not sure about the eyeball, but you are missing an alpha map on the lashes.

Best wishes,
Matthew

Hmm. Okay, from what I’ve gathered with some searching, this means that ZTrans is probably off and Alpha is probably not set to 0? I looked, and this was the case. It is now on, and Alpha is set to 0:

However, I still get the same result when rendering. I must be missing something. :confused:

The specular is way too high, bring that down and she will look alot less sweaty, regarding the transparancy, I still struggle getting that to work as I would expect, is the texture for the eye lashes also effecting the alpha? (what do you have set in the texture panel?)

I dropped the specular on SkinFace down to 0.1 and she does look a lot less glossy and plastic now:

http://gyazo.com/849ea13d75a48556a5b0588468f93b27.png

That’s definitely an improvement, thanks.

Also, this is what I have set in the Texture panel.

Originally there was no texture, so I added the one that Daz exported with the Collada file (which made no difference, either way). I also don’t see that any of the items in the Materials list were using the eyelash file that Daz exported (V4SmplLashesTr.jpg) under the Textures tab, which seems odd.

If you go further down the materials list, you should have a checkbox for Transparancy and Colour, are they both ticked?

It’s a bit more complex then that, unfortunately I can’t look at it right now for the details. After the import there are two shader options you need to un-select, I think it’s Z-trans and one other in that panel regarding shadows (they’ll be set you need to unset them). Now, you need to edit the .jpg that were used as the original transparency maps, take them to gimp and add a real alpha channel to them, save them as png. Remap the transparent texture to the new png and set (the button) so that they are antialiased.

Now the eyelashes are set to mix with the transparency layer, if you want their color to be controlled with the spec input I found (I believe it was) subtract worked better then mix.

My result was like this
/uploads/default/original/3X/6/9/69af442052dfe2e6a850fc21575270d1fc734841.jpgd=1283749209

I did put this through Lux, but the difference was not much different from BI, it just had more contrast is all.

You mean Alpha and Color? Or Translucency? In any case, I’ve tried every combination of the three of these without any luck.

Okay, I’m now using a .gif with an alpha channel for the lashes (a .png wasn’t recognized in blender’s browse menu).

Under the Shadows menu this is what I see: http://gyazo.com/7303a1a6484eab3c3de763b7ecb9bfb1.png.

Do you mean Receive Transparency and something else?

Still, with the alpha channel added I’m not having any more luck.

Here’s another question. I’m thinking I might have more luck using a Daz-exported .obj. These were the settings I used when exporting:

However, when I try to import it into Blender I get this message in the command prompt:

http://gyazo.com/fc0027937772dc10429a6ff7d733c895.png\

AttributeError: ‘Material’ object has no attribute ‘z_transparency’.

Why might that be?

Update: I went ahead and imported an untextured .obj and added all of the materials manually (wasn’t so bad!). And look!:

Okay, so I only kinda sorta solved the eyelash problem… since now there’s none at all…
And now there’s an “ear” problem that I can’t figure out for the life of me. :frowning:

For sure need to open up V4SmplLashesTr.jpg in Gimp, Layer->Transparency->Color to Alpha and select Black and save it as V4SmplLashesTr.png.

I haven’t much time right now but working on importing her so I can help with questions, anyways I had noticed that.

EDIT: don’t forget to do same to V4SmplEyeSurfcTr.jpg

Okay, here’s what I end up with. The key settings I hopefully have screen capped for you. The Premultiply is only for the “D” transparency textures. So 3 key settings, 1.) on the texture Premultiply the transparency texture 2.) On the shader, disable the Cast Buffer Shadows and 3.) On the shader (Options panel) disable “Traceable” (sorry, didn’t cap that but can if you need).

Attachments





How did you DO that? :eek:
You made her look gorgeous (I’m guessing a lot of that is lighting and an external renderer like YafaRay?).

So, this is my attempt to capture what you’ve done in steps:

  1. You exported as a Generic Collada.
  2. You imported the model,
  3. GIMP’d for black-alpha channels on V4SmplEyeSurfcTr.png and V4SmplLashesTr.png.
  4. Added the V4SmplLashesTr.png as a material for a6_EyeLash.001
  5. Checked Premultiply, turned on Z Trans, Set Alpha (under Z Trans) to 0, unchecked Cast Buffer Shadow, Cast Approximate and Traceable.
  6. Changed a7_EyeSurface.001 to V4SmplEyeSurfcTr.png (??)
  7. Applied steps in #5 to a7_EyeSurface (??)

It looks like you also changed the Hardness?

This is what I get:

What am I missing here?

Hey, sorry I’ve been running behind the past few days >.<.

We’ll start with

  1. You exported as a Generic Collada.
  2. You imported the model

Not quite, I actually exported as an .OBJ (and I did it from Poser7 instead of Daz). I then imported to blender 2.49b (before going to 2.54) so that I could use the OBJ import to separate the mesh by texture. I copy all the textures from teh DAZ directory to a //V4 direcotry (relative to the .blend file). Then in 2.49b I correct all the texture paths and move the transparent maps to .png. When switching to the .png I also deselect cast shadows and traceable buttons while selecting premul on the texture. I hide each object as I go along to “check off” that I have done it. Once done with that, I unhide all objects and make a second pass which is just to set smooth. Save the blend and then open the .blend in 2.54. An extra step you could do if you want is to join the body mesh (CTRL+J), just body tho, not lashes and hair and stuff. Then you can tab into edit mode and Remove Doubles, that will solidify the mesh.

I intend to try going straight to 2.54 and working through the steps but haven’t had the time just yet.

There is also a converter tool which may help too http://usa.autodesk.com/adsk/servlet/pc/item?siteID=123112&id=10775855 if you should try to bypass 2.49b.

Hopefully that helps some, keep asking questions if you need. I honestly should just slow down and write up a tutorial or vidcap one.

I appreciate your help with this. I’m learning quite a bit just by trying to tackle this one issue :ba:

Hmm. Okay, I do have a copy of Poser 7 handy, so I’ll try going this route.

First I tried going from Poser 7 to Blender 2.54 directly, this was my result:

That brought me to the same place it seems. Now I will try going from Poser 7 to Blender 2.49 as you have been doing so far. I tell you it’s a real challenge switching between the UI of the new and old Blender. But anyway, so I followed the steps you outlined, and ended up with this:

Same issues, only this time I have the older problem with the lack of alpha on the eyelashes it seems. :spin:

edit: removed the .blend file.

Please do not post a blend with DAZ’s V4.2 figure, it is a violation of the EULA that you agreed to when installing the figure. The base figure is available for free at DAZ’s store. You will have create an account and will in essence be buying it for $0.00. Use PayPal as your payment method, the store won’t charge actually charge anything it is just a formality

http://www.daz3d.com/i/3d-models/main-figures?cat=837&_m=d.

That last one looks correct, I’d keep working with that. Now go back and apply http://blenderartists.org/forum/showpost.php?p=1718987&postcount=12 to the lashes. I honestly think you’re almost there (for not using 2.49b).

… ya you can’t post the blend, otherwise this be very easy to help you. Simple mistake which you’ve remedied.

In my zeal as copyright police I failed to offer any useful advice. Blender 2.49b still, I believe, has the 16 materials limit for a single object. If V4.2 is import as such she will exceed that limit. If on the other hand you use the option to separate by groups when importing you should get all the materials but a disassembled model. The latest betas of Blender have removed the material limits and are stable enough to at least consolidate and otherwise sort the materials if you really want to use V.42 in Blender 2.49b.

When you import into 2.49b the most important option is to separate the mesh by material. The limit then doesn’t apply and again, you can join the mesh back togehter and “Remove Doubles” to solidify the mesh again. It’s a very simple work around to the limit.

I learned that one the hard way.

This is where I’m at:

http://imgur.com/wK8ohl.jpg

I wanted to show you that what I have for settings now for the eyelashes and eye-surface objects in 2.54. Still no eyelashes or eyeball appearing in the render. Unless I’ve missed something, my settings look identical to what you have above.

Is there something else you’re doing here that hasn’t been mentioned yet? I feel like there’s some hidden setting that’s just going to make things click.