UV alpha gives me a headache..

Hi!

First, I want to say that I searched the internet and this forum for a solution to my problem but I couldn’t find it. I apologize if there’s a similar topic here.

I’m quite new at blender and I just recently discovered UV texturing and this is one of my first UV texturing attempts. I tried to find a way of making roads to my scene by using UV and alpha parameters as stencil technique isn’t accurate enough for my taste. After days of experimenting this was the best result I got:

http://img411.imageshack.us/img411/9084/alphatrouble.png

Those white lines are the problem so is there any way to make it disappear? I made the UV texture with Photoshop CS3 and saved the texture as .PNG. I hope someone wil be able to help me.

In the Texture Panel did you enable Image: Premul ?

jrboddie1, you’re a lifesaver! Thanks! I can’t believe that the solution was that simple… :smiley:

THANK YOU! This also solved a problem I was having, saved me from making a forum post myself.

Here is my “checklist” that I use for textures with alpha transparency.

  • GLSL material
  • Materials: Render pipeline: ZTransp
  • Materials: Alpha = 0
  • Materials: Texture: UV and Flat
  • Materials: Textxure: Map To: Col and Alpha
  • Texture: Image: Premul
  • Texture: Map Image: Use Alpha