UV Alpha glitch

When drawing uv mapped textures with alpha in the 3d view, from one side of the poly the transparent area of the texture shows straight through to the world texture, rather than to other polys behind it, while from the other side it works as expected.

Is this a bug as it seem? If not, any ideas why this is happening and how I can get around it?


Also is there any way to make the alpha have effect when rendering? When I try it just renders as grey rather than transparent.

first, the render glitch:
sure seems like somthing I’d expect in the 3d view, not a render
but press the unified renderer button in the render buttons [ought to fix this]

and to get transparent faces you need to press ztransp in your material, set colA [alpha] to zero, and set some texture to modify alpha

The unified renderer has no effect on the 3d view.

Ztransp + Alpha slider only appears affects materials and not the UV texture.

Thanks anyway.

Make sure that the face’s normal is pointing the right way (outside) or that the TwoSided option is turned on if you want it visible from both side (you can turn that on in Face select mode).


The normals are all okay, and the polys are two-sided, and they transparent areas are, but the tranparency caries through to polys behind.

Normals are irrelevant for two-sided polys right?

Demonstrative files:


Could someone test the blend, and post here if they get the same glitch. If that is the case I’ll post a bug report.

you didn’t mention that your pic WAS the 3d view

it has always done this, all faces are drawn with zbuffer writing turned on, and they aren’t sorted and such.

When the game engine is started this changes [alpha faces dont’ write to the zbuffer, and the ztransp button in the material buttons will make them sorted by more than just the object’s closeness to the screen]