UV and Materials

Hey. I’m (again) working on the demo on my game, and I am enabling Light on the faces in the UV Specials. I have all of the textures mapped and am using the materials to shade them (keep the specularity low) and it uses the core textures and uses the UV editor just to find where they go. I get none of the lighting that I’m trying to get. How can I fix this?

Probably need to post a blend, or tell us more?

If you are using procedurals, they dont work in the GE, you have to bake them. Im sorry if I dont understand the question.

When you have use materials in the ge on, it uses a different renderer, then not having it turned on.

You need to map input to your uv map, and then use emit in map to. I think. I dont use the materials in the ge, because it slows it down too much.

Shaders dont work in the GE either, although, that is changing.

I just use materials to create materials and then bake them to use as textures in the uv image editor. Like making skin, or denim, or banana skins? LOL.

Did you read snailrose’s tut on light baking? Maybe that would help.

I find adding materials in the GE work very much better because you can make certain things shadeless, you can mess around with the spectularity and etc. I will post a blendfile in just a few minutes, we’re moving our computer into another room right now, and I’m on my laptop, which makes things hard to do.

Here it is. Notice that when you go into the UV edit mode, You have the Light button enabled in the Texture Face tab. I have a simple example of what I have in the Materials Buttons tab. Thanks.

If you enable Texface you get lighting. I guess it ignors the Texface buttons if you don’t have texface selected in materials. Intriging

you can change the draw mode in the MAPTO tab in the material browser, I like Overlay, and sometimes I use Multiply.

the above 2 allow you to use the vertex colors too if you want (press the Vcol paint tab too)

the Color slider works too, so you can tweak to your needs :slight_smile:

Textface button is a nice tip, thanks :slight_smile:

Thanks guys. Both Mmph! and Larryboy found ways to make it work. Thanks a ton.

EDIT: Well, It helped kinda, but How can I make A look like B? A is the In Game Shot and B is the shot that is just in Blender’s 3D Window.

Attachments


post the blend!

Ok. I will post a fraction of the model. I cannot post the full version because it is of the castle we are using. Here is the fraction (and the part that needs the most help).

Its your lighting dear fellow. You have completely flat lighting on our castle. I deleted 3 of the lights. moved one to the side and hey presto… moody lighting…

Thanks. I have no experience with lighting at the moment. I should start looking at it to make my lighting better. Thanks and I’ll see if this works.