UV coordinate - Auto Triangulation

Hi everyone,

I have a problem when I use the UV mapping option with my image texture.
I made a simple plan, I created my material and texture and when I render it, the image on the plan have been cut into 2 triangles. It’s like blender have automaticly triangulate my plane. It wouldnt be a problem if the image was cut into 2 triangles and correcly apply on each triangle on the plane, but it doesnt do that.

Check this image for more detail :


I’m new here, so tell me if I miss something on the forum that could help me. :slight_smile:

It looks like you need to unwrap your plane. Blender won’t automatically map the plane correctly when you create one.

Well I tryied to to do this and it worked. The thing is, I present my problem as a plan, but in the real situation, I want tu apply a leaf texture on a lot of leaves in a tree created by the addon Sapling. I cant really unwrap all my tree, it would be way too long…

I want tu apply a leaf texture on a lot of leaves in a tree created by the addon Sapling. I cant really unwrap all my tree, it would be way too long…
You only need to unwrap one leaf and copy the uvs to all the rest (see image)
or have the leaves as linked duplicates so each is the same as the original leaf
or if it is just a plane don’t use UVs at all but Generated coordinates


Hi Richard, thanks for the help.
I’m just now sure I got it.
So I select a leaf alone in edit mode (all the leaves are a single obect with the Sappling addon), I unwarp it, so I have a simple rectangle. Then I go back to object mode and Join as UVs my object like u show me in your image.
If what I said is right, I did it and it sill not working. It seems the UVs haven’t been apply to the rest of the leaves. Am I suppose to see a rectangle in the UV Editing screen? Cause I dont. Print screen for more details :


I’m not* sure I got it. ^^
The image is not very clear… but well, now my texture apply correcly on the leaf I manualy unwarp, but the others are fully white.
Could u (or anyone reading this post) explain me just a bit how the Make Links (and Join as UVs) works? Should I separate all my leaves to make everyone of them a single plan object? If yes, how can I do this?
Tx for your support :wink:

I read many post on many forum, but no one seems to have a solution… I cant (or I dont know how to) make a tree with one leaf and duplicate it everywere on the tree, so I cant really use the second tip.
For the Join as UVs, I tried but I think I cant apply this cause all the leaves are considere as 1 object. I made a test to know if I really got how to apply this technique correcly. I made 2 plans. I put a texture on it. (I starded from cratch btw) I make the mapping on the texture by UV coordinate (I know I should make them as generated but on my real project, generated texture make all the leaves one the tree look like one big leaf). So back on the test, I unwarp one of the 2 plan and Join the second as UV. It worked. So I’m not that newb :P.
So, I’m starting to think I cant apply a texture one each leaf with the Sappling addon.

If anyone have a revelation, I’m begging you, tell me! :slight_smile:
(If not, have a nice day anyway :stuck_out_tongue: )

Ok. I’m a bit tired of searching on it on the internet, so I change my question : anyone knows how to make a realistic tree? The Sapling addon was nice to make many trees easly random, but my problem make it impossible to use if I want to put an image texture on leaves. (Too much leaves to separate them or unwrap them).

Any tip for christmas? :slight_smile: I’m starting to think no one got this problem before… but its weird, there have to be someone who used UV coordinates before :S. I want to continue my project so badly, but I’ll have to deal with this problem again a lot if I want my realistic leaves.
Merry Christmas anyway to all this forum!

I have not tested this, but it seems like it should work: since all your leaves are in one object, go into edit mode with that object, separate by loose parts, apply UVs on one leaf, select all other leaves in object mode and do the join as UVs, then rejoin all the leaf objects.

Hope this works!

Oh my god! Santa DOES exist! :stuck_out_tongue:

First, tx everyone for trying to help me.
I solved my problem. The solution? Unistall and reinstall Blender! (No I’m not kidding)
I’m now running on v2.65 (I was on 2.63). I dont know if there was a bug with the auto-mapping, but now it work! :smiley:

I feel bad a bit for having created this post when the solution was so simple! ^^

The good thing is, now I know this forum!

Best regards!

PS : I dont know how to make this topic “solved” if any moderator are reading this.