UV distorted after extruding geometry

So I’m still somewhat new to blender and have been trying to learn to use it to modify 3d objects I’ve made elsewhere. I imported an .obj file of a greave I’m making for an outfit so I could add a beveled edge which I did by extruding the existing geometry. And it all looked great until I threw on a texture I use to check my UVs. Here’s what I get:

You can see at the top and bottom the image texture I’ve applied has become strangely distorted. But the UV itself looks fine:

So the question is why are things becoming so distorted and how do I fix it?

If it matters, the original object was created in Marvelous Designer. I brought it in as a .obj file, and MD did much of the initial UV layout for me. In Blender I chose the edge loops at the top and bottom and extruded and scaled them to make the edge.

I thought maybe that the edges had ended up onto of each other in the UV layout, so I would select what looked like the outer edge loop by alt right clicking and then use G to try and move it. And it looks like there is another edge there, but when I move that edge, there’s still another edge there, and still one more under that and so on. I’m pretty sure I only extruded twice. But there seem to be an infinite number of edges piled on top of each other.

It’s a simple fix, but there are a few small steps.

  1. In the 3D View, select all original quads. I would do this by selecting the outer ring of extruded faces and then inverting selection.
  2. Within the UV Editor, select all and pin §. All visible verts should be highlighted in red.
  3. In 3D View, select all geometry and unwrap (U, first option).

Hey, with out seeing the file my guess would be just what you said “edges all piled on top of another”. Can you put the model in ‘Edit’ mode in Blender & select every thing & hit ‘remove doubles’ to see if that fixes it ? Also a question - is the pic of the UV lay-out from Blender ? Just wondering cause if you look at the lower right hand corner you see only 3 faces, the first pic were you see 3-4-1 going down you have 4 faces which are the distorted one (row) - so that could be the issue, just what you said about being on top of each other. Hope that makes sense

That’s expected behaviour. You’ve created new faces, so you’ll have to either unwrap them, or put up with the texture being stretched at those locations. It “looks” fine. But it isn’t. The newly added uv points are directly beneath the originals from which you did the extrusion. In essence a single pixel’s worth of information is being spread across those new faces. That accounts for the stretching.

If you can’t solve the issue yourself, then consider posting the blend, or pm’ing someone with it. It’s almost always the fastest way to get the job done. :slight_smile:

So thanks for the help. A combination of things worked. Or mostly worked. I did have to Remove Doubles. Didn’t know about that, very helpful.

The method for selecting and unwrapping kind of worked. The way blender was unwrapping was not very good, and it would have been a huge amount of work to get it working.

By accident I ended up separating the two areas of my object (hit P in the wrong window) and when I just the edges selected I was easily able to make a good UV for them, because they kept the good edge of the old object. I’m still experimenting with getting exactly what I need, but I actually may be fine with the two separate objects that have UVs that match. I’ll have to play around more.

Thanks for the help.