UV image showing up in 3D view, but not in render.

Hi all,

I am modeling an insect as part of a larger project. I have modeled everything myself, but the wings I downloaded from here (bee wings), essentially because they come with a photo texture that fits exactly with the wings. The geometry is included as a .obj file. Now, when I imported the .obj into blender, I found that with all the vertices of the wing selected in edit mode, a map of the wings appeared in my UV editor window without doing an unwrap. This map was not a proper one, but when I loaded the image to it, the wings in my 3d view became textured with the image, on both sides, perfectly correctly. This is exactly what I wanted, however when I hit render, the wings remain the default gray.

You can see the map and the textured wings in this pic:

http://www.imagechicken.com/uploads/1269711015069600800.png

I remembered to add a new material, and click the TexFace button. I am using blender 2.49.2. I have never worked with UV maps before, and I realise I am probably doing wrong by not actually unwrapping, but it is just frustrating that I have the result I want in the 3D view, but not in the render. Can anybody enlighten me please?

Cheers,
Joe.

check to see if normal are outward or faces wont appear in render !

salutations

If you haven’t already, you need to add the texture to your material, mapped to UVs and affecting the colour.
http://wiki.blender.org/index.php/Doc:Manual/Textures/Options/Channels

Richard

Normals are facing outwards, I tried adding a texture with the wings image, with UV map input and set to col - all to no avail.

I also notice that I cannot even add a normal image texture to the wings, or even change their colour. Can this happen when you import geometry from a .obj file?

Attach or link to your blend or a blend that shows the same problem.

Try this:

Go to the Materials panel .

Set ‘Map Input’ to UV

Go to Texture panel (F6)

Set ‘Texture Type’ to Image.

In the ‘Image’ section, Load the image of your insect wings.

Render the image…

Journeyman.

but then don’t use this texface for UV
this is shortcut method and not very usefull anyway

so go with the full UV texturing
add your mat image then map in panel set UV
and it should work much better that way

salutations

Well I have successfully UV mapped the abdomen of the insect today, so I don’t think I am doing anything wrong in that respect. It seems to be that the wings themselves won’t accept any sort of material. Very weird. I got them here:

http://www.mikheyev.rgkp.com/files/bee_wings.zip

Would anybody mind seeing if they have the same problem please?
Thanks for all the help and advice, guys.

if you miss it it can become tricky to correct
sometimes it;s better to append into anohter file and redo the UV
and then it might work better

thanks

When the wing is imported it had two material assigned to it. Delete both and start from a clean slate with a new material with the wing texture applied, mapped to the UV coordinates.



wing.blend (870 KB)

Richard

How did I not notice that! Thank you so much.