UV images aren't showing

Dear Blender Friends,

I know there’s probably an obvious answer to this, and I’ve gone through all the checks (see attachment) but for the life of me I can’t get UV images to render on some cubes.

I unwrapped each face, loaded each image into each cube (they’re software boxes) and lined up the mask. I then created a material, (maybe i should have done this first??) for each cube, and made sure it had “Tex” set.

But when I render the cubes look solid.

My brains are starting to die on me. I would really appreciate some help.

All the best.
Pablo.

p.s. please see attachment

Attachments


Have you gone to the texture section of the shading menu (the spotted box on the header, not the panel under materials) and set the texture to load the image? Loading the image in the UV editor simply loads the image into memory and lets you see it via the viewport, but it doesn’t add it into the material settings.

Hi there,

I’ve just checked under the shading menu / texture button and it says no textures loaded. (See attachement.)

What should I do? Create some textures? This will make my images in UV editor show?

Thanks!
Pablo.

Attachments


Hi

I don’t know if you tried this or not - but if you hit F5, go to the materials tab and hit “texface” then render, your UV applied materials should then show up - this is necessary everytime you apply a UV Image texture. You can also apply an image texture according to your last posted image - but that will NOT be UV mapped.

Hope that helps

just to make it clear:
to use a texture with the uv coordinates
unwrap the mesh
go to texture settings, add new texture, type image, and select the image
then go to material setting, and in the map input tab, select “uv” as the coordinates
make sure “texface” is off
render

No Akiviri,

No, I hadn’t tried that - doh!! I knew it had to be something obvious. That was a sure kill. I’m pretty sure you nailed that son of b****. I was getting very upset. Thanks buddy!! :smiley:

All the best.
Pablo.

Hi Blender Friends,

Confirmed! What Akiviri suggested worked. Question is … what was I looking at? I was looking in EDITING (F9) Texture Face panel and had selected “Tex” under Active Face Mode. (see image in my first post). I believed this to be what I now know isn’t the right way to enable UV images. So what’s EDITING (F9) Texture Face about?

All the best.
Pablo.