UV in 2.9

i unwrap a mesh in 2.9
and using 2 PBR nodes for the material

but now i cannot see the unwrapped UV in UV editor !

so is there some trick here to see the UV image in UV editor ?

happy bl

1 Like

No. As usual (2.7, 2.8, 2.9) in edit mode all UV’s from selected faces are visible…

got one file in 2.9 and cannot see the darn UV map

let me check size and see if i can upload it
i’m stuck for now in 2.9 not the later version

happy bl

here is file

there is a UV map for the object in properties panel
but don’t see it in the UV editor

not certain why
tried to redo the unwrap and got same issue
and don’t understand why i cannot see it

Z-whate-1.blend (1005.2 KB)

thanks for feedback
happy bl

I think you might be looking in the Image editor instead of the UV editor. Check in the corner if the workspace is set to “Image editor” Rather than “UV editor”:

very strange
look at top i opened up on top header the UV editor

but at bottom it is image editor

trying to understand why ?

how come ?
is this a bug in 2.9

never had this problem before with 2.9

happy bl

Yeah, I’m not sure why this is the default, it certainly confused me when I first switched from 2.79. But it can be changed pretty easily, and if you do that in a new file, and save it as a new start up file, you wont have to worry about it again.

how do you change it ?

my 2.9 is not installed just the Zip local one
and the default start file goes to the UV editor

looks like it is only this file that has this problem!

happy bl

Ah, sorry for the late reply, to change it, just click on the icon in the bottom left corner and select “UV Editor” instead

not that one

more like why when you click on top icon for UV
it goes to this UV image instead of the UV editor!

is there a parameter for that ?

happy bl

The top tabs change the workspaces that store different layouts, which are design for different tasks. Whoever setup the UV Editing Workspace saved it with the image editor active. The was likely an error. It’s and easy fix so maybe report it. As Strike_Digital mentioned you can correct this error by yourself by creating your own startup file.

  1. Start a new file
  2. Change to the UV Editing Workspace
  3. Change the screen area that has the Image Editor in it to UV Editor
  4. Go to : File → Default → Save Start up File

Now every-time you start Blender the UV Editing workspace will have the UV Editor active by default.

Note: This will overwrite your existing start-up file so if you have already made a custom one you would need to back it up or amend that one instead.

Edit: Sorry I didn’t read you previous message properly. You mentioned it was only happening in a specific file.