UV Inage Editor Will Not Let Me Select An Image

Hi All,

I have a mesh with multiple materials on it.
Part of it is a brick wall.
I have loaded a brick wall texture and I can see it.
I place the mesh in edit mode and deselect all faces except the faces belonging to the material id of the brick wall.
I press U to unwrap those faces, I use Smart Projection.
I see the UV mapping scheme displayed in the image editor.
Now I return to the image editor and select the brick wall texture I can see in the list, but it never loads into the area I just unwrapped.
I do see the mapping being applied to the mesh in the 3D viewport.

Am I missing something? I assumed Blender could do a UV map for each material in a multi-material mesh. Is this assumption flawed? If so, how do I map, just part of my mesh?


I had a problem with that too. When you try to load the image, and it doesn’t, try CTRL+Z, it worked for me.

If it is the same ‘bug’, probably the texture will render, it just doesn’t show in the UV window.

I discovered that as soon as I selected a face in the UV Image Editor. BAM the texture popped into place. Strange work-flow indeed.

Sounds like a relict from the face select mode in 3D view, when image in UV was chosen by the recently selected face in 3d view.
May be you should file a bug report.

I’ve had this problem too! Had me confused for quite a while, as my first attempt at UV mapping worked without issue, then I cam back to try again, somehow not selecting a face or not arriveing the UV editor by the same route, was tearing my hair out for ages till just clicked a face and ping! Image appears…

Whats the point in filing bug reports, 2.49 is going extinct!

A lot of code is ported from 2.4x. That is: copied to the new project and tweaked until it compiles again. Very unlikely that things like this will disappear that way.