UV Map Editor and Lost vertx issue Please help

So here is my problem; I UV unwrap and get random vertices that bind to the unassigned portion or the top left of the UV editor. what am I doing wrong ?http://photos-e.ak.fbcdn.net/hphotos-ak-snc3/hs131.snc3/17835_414997610404_749025404_10478042_7930032_n.jpg
Model has no loose vertices and everything is one object. I have been searching everywhere for an answer please help???:ba:
I can’t see to edit them properly in the in the UV editor cause the blue square or unassigned box moves with the vertexes :confused:

make sure all your normals are facing in the same direction. ( ctrl N with all faces selected in edit mode ). sometimes inverted normals can cause strange things to happen during unwrapping. btw, are you using blender 2.5, or one of the 2.4 versions?

yes I am using the latest version so 2.49b i believe it is. I have tried this solution and nothing changed. thanks so much for the reply have any other suggestions?

I can post the model and any other render shots if it will help

yeah, post the blend file.

This is my blender File it’s a right glove and it does the same thing as the armor but less vertex problemshttp://www.megaupload.com/?d=VSY6AQKO

Why don’t you make true unwrap - make seams (ctrl+E, make seam), I think that blender don’t uderstand how to unwrap this model - you need to suggest it)))

wait wait i got it to un-wrap properly by seaming then pressing U and commanding un-wrap before i just selected all vertex and that’s what it was giving me all that after 3 days of looking for an answer i knew it had to be something silly. thank you all so much for you help this has been a huge help.

True un-wrap was the problem thanks again

This topic has Been solved

Why is this model triangulated? Importing a mesh from another app is always a problem and there are some solutions here.

I’m not sure what you mean Please elaborate or post me a link