UV Map is all aligned yet the final product is distorted?

Hello everyone. I’m a total beginner at Blender, so bare with me if this is some newbie mistake. I wanted to test out the texture for my practice 3d model of a phone, and got this.




This is not what I wanted. This is my UV Map.

If it helps I am using Blender v2.76. I have put the texture to a material texture, yet nothing really changed.

Can you upload your blend file so we can look at it?

Here you go, I included both the texture and blend file


kiyko.blend (520 KB)

You are using a subsurf modifier but you did not take into account the changes to the mesh this modifier makes when it is applied. Turn on/off the modifier to see the difference

When you UV unwrap there is an option to take into effect the Subsurf modifier


It turns out that was already checked. Unchecking it didn’t help much either. Also is it normal when I select a vertex on the uv map, it selects another vertex thats on another piece? For example when I select a vertex on the top of the front of the phone, it also selects the vertex on the long vertical rectangle that’s the sides. I just decided to stay away from the subdiv for now, since the normal version is fine.

Add additional edge loops to minimise stretching of the texture from the subsurf



Thank you very much for your answer, for future reference, should I make the UV Map AFTER I apply the subdivision modifier? (After you reply to this question I’ll set this as solved, since I don’t know if setting it as solved locks the thread.)