UV map is black

Issue
As the title says, the UV map is completely black. I haven’t placed any seams. The model was done trough simulation. It was made as a cube with 30 loop cuts horizontally and vertically then simulated, I also beveled a middle across and then inflated the middle outwards,I applied a shade smooth and subdivision modifier.

What I want to achieve

If I can get the UV map exported as a PNG, like in the photo on the right.

Research

I found out its because of autosmooth, but I had it disabled all the time, other than that, haven’t found anything.