UV Map Not Showing Up In Layout, Modeling, Or Sculpting Mode

I am a newbie here with any 3D rendering. I just recently used a tutorial from YouTube and it made Blender look less intimidating, but I’m having trouble with the UV Map. It looks beautiful in the UV Mapping, Texture Paint, and Shading modes, but in Layout, Modeling, and Sculpting modes, the object is plain.

I’ve even followed these tutorials here:

https://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/UV_Map_Basics

Part of where I’m stuck is I can’t find the “Mapping Menu” so I can set the coordinates to UV and Map to UV Map. I’ll show you some a screenshot of what it should look like, and I have other relevant screenshots that I can also upload in replies since I currently cannot upload more than one embedded media item per post. I even have the appropriate Texture and Material properties.

What am I doing wrong?

The key is most likely these settings in the upper right corner of the 3d viewport:
image

The 4 circle/sphere icons represent 4 different shading modes: wireframe, solid, material preview, and rendered

Material preview and rendered mode should both show your uv mapped texture.

2 Likes

I know. The thing is, it is NOT showing up in the other modes:

It only looks like that in the first three modes. And when I try exporting the object, it comes out looking plain and unmapped - just the mountain object. What am I doing wrong?

You’re in solid view, press Z and switch to Material Preview

1 Like

Thanks! Does rendered view work as well? Or will either that or Material Preview export with the mapping?

Rendering view works as well. Export should keep your UV map- what are you exporting to?

Obj. For milkshape. I’m working on a custom distant terrain for Sims 3. Far too few of those. Might try generating one for a futuristic cityscape distant terrain sometime, using an AI generated picture. Right now though I barely know what I’m doing.

It doesn’t look like you actually have the landscape selected in your screen-shot…to show the UV (if present) the object has to be selected ( orange outline around it ) and it will only be there if you are in edit mode…

Also, I just checked…What version of Blender are you using?
As I don’t get UV data in Paint using Blender 3.3 but 3.4 is OK