UV map problem.

I’ve only done a few small projects in Blender, so I’m still fairly new to it, especially when I have a problem.

I’m working on a 50’s style refrigerator, which I modeled as separate objects; the main body, the handles, the logo on the front door, etc. I then created the UV maps for each part, with no problems.

When I joined the objects into one object, the UV maps also were joined as I expected, with one problem that I can’t figure out. The UV of the logo on the door is reduced to a single dot.

I’ve tried enlarging it, but it remains a dot. I can select the dot in the UV map, and the logo is selected in the 3D view. I’ve tried Ctrl-A to reset the scale/rotation but that has not helped.

I can give any other information that may be helpful.

I really don’t know what else to do, and help would be much appreciated.

I couldn’t say what happened there just yet. Have you tried unwrapping the logo again, and then shrinking back to the appropriate size?

Best to always upload the *.blend file.
If you dont want to upload the whole refrigerator, only the logo would do too, ofc. :slight_smile: