UV map renders all black??

Im having a problem with my UV map. After applying it to my model and turnin TexFace on in the material panel, i tried to render it. Everything showed up black. There is a light source and a camera in place so is there something else I forgot?

Make sure the faces have a texture assigned to them in the UV image editor.

Also make sure the option ‘tex’ is on in the UV texture options and see if you can see it in the textured view.

Texface is generally only useful for the Game Engine, your UV texture should be set as an image texture for the material and set to UV coordinates.

I can see he textured model in the 3d viewport, and all the faces have the assigned texture. I also have the tex option enabled, and it still isnt working =(

nvm, i fixed the problem =D