UV-Mapped Label is Truncated

I’d like to post this in works-in-progress, but not until this technical problem is solved.

I have an aluminum can and a .png image for a label. In the following screen capture, in the upper right 3D view, you can see some of the can mesh points selected (orange) and defined as a vertex group. I have a nice (but not yet finished) metal material for the whole can, and another material using an image texture for that special vertex group. Note that the top and bottom points are near the rims of the can.

The render in the big window, however, shows the label graphics going only so far, falling short of the rims by a large margin.

I can cheat and pull the vertices in the UV view out, and see all the contents of the label, but still the graphics on the can is confined to the same truncated zone.

Here is my material nodes for the label material, and a view of the label image, which has about a 10:1 aspect ratio:

I thought maybe vector mapping was clipping the image, but that doesn’t explain it. That affects what is seen in the render, within the zone where Blender does bother to paint the image’s pixels, but it is not clear why that zone is truncated to less than the vertexes selected and assigned this texture. Is this a bug in Blender? Or did I forget some secret setting?

I have a vague memory of dealing with a problem like this in Blender some time ago, but don’t remember enough to find anything online.

Cats all over the world are counting on someone finding a solution to this problem!

The subdivision is the culprit. In modifier tab try to uncheck subd. UV. You can see what is happening if you check the subsurfaced mesh in edit mode.

Hope it helps.

Crease a bit.

Have you checked ‘subdivide UVs’?

@DruBan: i was tinkering with this checkbox on modifier tab - it had no effect on this. Am i doing something totally wrong or this should be considered bug?

Just something to try… It may matter only if you unwrapped BEFORE you added the modifier, did you try that? Also there might be an issue with the scale being applied after the unwrap. Can’t tell which of these without the blend, all the answers are possible but only one of them applies to the OP, right?

Good answers, at least upon reading them. But which bits of advice will work in this case? I don’t recall if I applied the subdivide before or after the UV work. I have the Subdivide UV checked on. Turning it off, no change.

What worked just now: adding a few more loop cuts around the side of the can.

3D artists using Blender are the smartest and most generous people in the world!

Now to make labels for some other interesting (to cats) “flavors”…

My not so educated guess would be that Subsurf stretch should be some kind of squared function of distance between loops. More you add loops, smaller it gets. Cons - you get more geometry. I’d say, add creases.
Can’t freely bet on eating my hat (not that i use it a lot or it is my object of pride); usual thing i do is Unwrap and only then add Subsurf. I was a bit shy to share stolen from this thread original texture (scientific reasoning - keep experiment clean ;)) on top of that, so file is absent. If scale is not applied before unwrap blender throws warning message - did not see that coming this time either.

@Eppo It’s not broken or buggy, but effect is subtle in some cases and obvious in others…

Cylinder subdivided to the third power, top image with 'subdivide UVs checked, bottom one without that option.

@OP: glad you got it to work but an 80K polygon can is getting way up there for no good reason!


Guess, another proof that 2x2 can be 5 and that 2+3 and 3+2 is not always equal 5 . Thanks for the effort - i liek that house :wink: !

Interesting example, that round house.

Yeah, the can model has a few more polys than truly necessary, but oh well. Once the final images are made, it’s just a small cluster of magnetic blips on the disk, not as small as could be. Maybe I’ll put the mesh on TurboSquid, in which case it’ll be wise to simplify it some.