UV mapping a transparent PNG

This seems to be a common question, but none of the solutions I’ve found so far have helped.

I’m trying to make a model with a UV mapped PNG texture, which includes transparency. Predictably, when the scene is rendered the model has black everywhere the PNG texture is transparent. Here is what I’ve tried so far:

  1. Ensuring the PNG actually has transparency and the texture/UV map are being applied to the mesh. Both are true; in fact the model looks correctly transparent in 3D View, just not in rendered images.

  2. Making sure the Transparency option for the material is checked. It is.

  3. Adjusting the Alpha option for the material to zero. This was my first instinct since I’m pretty sure that’s how it was done in version 2.43; but I’m trying to use 2.79 now, and changing this setting makes the entire texture transparent indiscriminately, including the parts that are supposed to be opaque. WTF Blender.

  4. Making sure the Game Setting called Alpha is set to “Alpha Blend”. This did not result in any apparent change.

  5. Making sure that the image setting Use Alpha is checked. It is.

  6. Making sure that the channels being drawn for the image include both Color and Alpha. They do.

  7. Enabling the Influence - Alpha setting on the texture. I’m not sure if this is even the correct approach since I’m using a UV map. Either way, no apparent change.

  8. Setting the Transparency setting on the material specifically to Z Transparency, or setting it specifically to Mask. Different answers suggested different things; neither one showed any apparent difference.

  9. Selecting the Material Setting “Emisison & Transparent” and/or “Use Alpha” when importing the image. Neither of these options appear in the Import Options panel for me.

  10. Using shader nodes to render the material. There seem to be several different variations on how to implement texture nodes for alpha transparency, most of which include long complex trees and no explanation as to how the person created them or which parts are relevant. My texture node tree is totally empty so no help there.

Is there some other option that I’m missing? I’d like to not use nodes if there is some other alternative; it seems like a vastly overcomplicated solution for something that used to be easily fixed. But at this point it seems like I’ve run out of solutions to try.

The simple answer is, where the PNG is transparent, there needs to be some other material as you are masking out the “decal”.
You say you don’t want to use nodes as the yare complicated, but you can build a “node tree” within the material section adding shaders. Conversely, a node tree built in the node editor shows as “layers” in the material editor.
The highlighted material I built in the material tab, only hooking up the alpha to hte mix factor in the node editor for efficiency. One cube has the decal mixed with transparency, the other with a glossy shader.

Blend file: Alphapng_test.blend (1.7 MB)

Of course, this not may be what you’re after. :wink:

Thank you very much! This seems to do exactly what I wanted, and I have it working now.

If you’d like, I can show you how I went about building that shader tree without using the node editor if you think it would help.