UV-Mapping a tube. I just don't get it :(

Hi,

I try to unwrap a tube. As you can see on the right side of the screenshot the result is far from perfect. I try to achieve an unwrapped tube what I image as one big uv-island wider than tall. For that end I added a seam following one edge loop of the longer “side” of the tube.

The resulting pieces are additionally very distorted, the longer parts in the real mesh are the smaller parts in the UV-View and vice versa.

Any ideas?

Thanks in advance.

Attachments


go to side or front view and project from cylinder

Thanks for the help.

But I don’t find the option you are referring to. I use version 2.46. Is it named different now maybe or am I looking at the wrong location (I hit u, see the screenshot)?

Attachments


oO
You’ve got it there: Cylinder from view

Well, then I think I do something definitely very wrong. My Uvs look totally distorted. :eek:

Attachments


Try Unwrap (Smart Projections) I get the best results from that.

Well, thanks for the help but there it even looks more odd consisting of a (felt) million parts. I suppose my model is somehow totally wrong. I’ll check the feature again with a different model, maybe then I’ll get the hang on it.

Oops, looks like some things have been “optimized” away for cylindrical mapping.
I remember because i did code the UV button panel with all kinds of cylinder maps.
Well the buttons panel is gone with the “Face select mode” :frowning:
The only remains working seems to be:
Align your model with the rotation axis in parallel to Z go to side view and fire cylinder from view.
<edit>Hum it seems to be sufficient to choose a view such that the rotation axis is in “top down” direction.
Be aware the operation needs a center so watch your pivot point settings. </edit>
BM

The center could well be the problem here. Thanks for the tip. I’ll try it.