UV mapping and faces that are not assigned a texture

As i tried some things with UV mapping i find out that all faces that do not have a texture assigned to it appear white. Is it possible to assign them a normal material that is no texture? Or do i have to assign all faces a texture if i did it for even only one face?

Thanks for help,
Marco.

This is a question I’d like an answer to as well.

I know that if you play with the mat/vertex buttons in the F9 editting window, you can assign different colors to faces (there’s several tutorials around that talk about doing this in different ways). However, I’ve a mesh for which I’ve UV unwrapped part of it and given it a specific .jpg texture. The other parts of the mesh currently unwrapped I’d just like to use Blender texture/color schemes for.

Is this possible, or do I have to UV map the whole thing now? If it is possible, a pointer to a tutorial I’ve not been able to search or google would be highly appreciated.

Thanks.

Okay, in the last couple of minutes I had a brainstorm…which worked, amazingly enough.

I tried separating off the part of the mesh I wanted a different color, making that new mesh a garish bright blue as a test, rejoined the two meshes into one, and finally removed doubles. It did work as far as getting a colored material, but there /has/ to be an easier way.

Yes?

I know that you can assign different materials to different faces. I am positive that it is very easy to find a tutorial to describe this, but in case its not:

  1. Start by assigning a material to your object. This will be your UV mapped material in this case. In the material options, make sure you have ‘TexFace’ Selected, and that you have all your specularity and raytracing options the way you want them.

  2. Map the faces with the texture you want to use.

  3. Create a new material, keeping ‘TexFace’ unselected. Set up your material however you want to.

  4. Go into the edit buttons, and you should see on the furthest left panel (assuming your using the default Blender set-up) something that has the name of your current material, its color, and something that says ‘1 Mat: 1’, followed by a box with a question mark. Click the ‘New’ Button, and go back to the materials panel (F5 shorcut), and select the material without ‘Tex Face’.

  5. Returning to edit buttons (F9 Shortcut), you should now see that the name of the material without ‘TexFace’ is above the Material Buttons. Go into edit mode, and select the faces you don’t want to have the UV Texture on. With the faces still selected press ‘Assign’ back in the Materials buttons on the Edit Panel.

I hope this helps, and If it is confusing consult a tutorial.

Another solution:

Assign a texture colour as you normally would. Then in the next texture slot assign your uv-mapped texture. If you do not want the texture to be shown on some faces make sure they are transparent on your painted texture. Your texture will have to be a format (eg. png) that has an alpha channel.

GreyBeard