UV Mapping issue | Loose Geometry . . . but not quite

Hey there,

I’m currently unwrapping a character model but I noticed some faces flying around on the UV Map even though they have no seams.

There were actually more loose faces but I managed to stitch them somehow. But this last face can’t be stitched.
I checked for:
are these faces loose in 3D space? - no
are there non manifold edges that might interfere? - no
accidental seams? - no
stitchable? - kind of, but no

I unwrapped manually without smart UV
this is Blender version 2.91 on Windows 10 Pro

I have no idea how to search for this problem on the internet. I couldn’t find any solutions myself or provided by the internet, so I hope I can find my salvation here.

Best regards

Looks like an underlying face. I would delete it. Select the three vertexes that are not connected the the rest of the geometry and delete them. In the right hand side of your example you can see the face only has one vertex that is part of the mesh (the far left one)

If I would delete this face, I would have a hole in my mesh. Trust me, I tried. I am pretty sure my mesh is clean, because I checked for loose and open geometry before unwrapping.

It looks like there are 8 faces ontop of that one, the vertexes that I have circled in red are not connected to the rest of the mesh. Have you tried deleting those three?


Edit I have circled in blue where that face should be, there seems to be a hole there.
Edit 2 if the face is in the right position in edit mode make sure the three vertexes are not doubled. try merge by distance.

What seems to be a hole is just a crooked mapped texture. There is no hole in the mesh. And there are no doubled vertices nor faces in edit mode. The face is only loose in the UV Editor. That is why I am so confused, because Blender itself cannot detect mesh issues here.

Anyway I found a fix. I deleted the face and created a new one.

Thank you for helping me :slight_smile:

1 Like

You are welcome. I am pleased you found the solution, there must have been something wrong with the geometry (maybe flipped normals or vertex order).