UV mapping: Mysterious untextured faces?

Hi all,

This may be the wrong place for this post, but I’m super new to Blender and 3D modeling in general, so “Basics” seemed appropriate. I’m working through the UV mapping part of Katsbits’ Blender basics tutorial, and I can’t figure out why the texture isn’t being applied to all the faces of the object.


It only shows on the “front” face of each piece of the chair, meaning the texture doesn’t display on the back of the chair, under the seat, on the sides of the seat, or on any of the other three faces of all four legs. From behind:


Additionally, one of the legs doesn’t map correctly despite having its seams set up exactly the same as the other three legs. I’ve triple checked to make sure the seams are right, and I’ve redone them more than once.

Things I know:
-The texture is set up as part of a material, with its mapping set to UV.
-The empty faces are still black in Material and Rendered views. In Solid view, the brown diffuse color of the material covers the entire mesh, but in Material view, it doesn’t affect the empty faces.
-I did try quitting Blender and restarting; no dice.

Any suggestions welcome! Running version 2.75 on Mavericks.

Invalid attachment?
That guide is pretty old with still valid topics. But the version of blender is pre-2.5 so you’ll find so many differences on the interface that I suggest you to find another guide
For your particular problem I think that you can doublecheck if the object mapping is UV instead of Orco

Sparazza

Do you have a lamp in your scene that is illuminating the faces that are showing up as black ? Try setting the material to shadeless so you can see how the texture is actually mapped onto the object

Additionally, one of the legs doesn’t map correctly despite having its seams set up exactly the same as the other three legs.
You haven’t told us what the ‘incorrect’ mapping is.

You have also failed to supply a blend file (including all textures) in your post as you should have done.

I tried to edit my post to fix the images, but somehow the post disappeared in the process (needed approval, maybe?). In case the post is actually gone and not just hidden, my issue is that a decently unwrapped mesh is showing the majority of its faces black/no texture applied. Also, despite correctly seaming the legs while following along the KatsBits tutorial, one leg is still super messed up.

[ATTACH=CONFIG]390483[/ATTACH]

Below image showing the black faces:

[ATTACH=CONFIG]390484[/ATTACH]

I’ve been relatively able to navigate the changed menus by looking at other tutorials, and I’m assuming the panel my tutorial is calling “Map Input” that used to be accessed via F5 is now the section of the Textures pane called “Mapping.” I already switched the Coordinates from Generated to UV, though it made no difference. There was no option for Orco - is Generated the new Orco, or am I looking at the wrong window still?

I wish I could facepalm harder! I kept looking for something like that, but I guess I was always looking in the wrong places. I guess future education will have something to do with moving the light source around so the shading is less intense.

You haven’t told us what the ‘incorrect’ mapping is.

You have also failed to supply a blend file (including all textures) in your post as you should have done.

My bad! I might be using the wrong words, but I’ll try. On the UV editor, the four unwrapped legs are the rightmost islands on the texture. Three of them unwrapped correctly, but the fourth still looks like it was never seamed, even though it has been. Attempting to manipulate the vertices in the UV editor to try and straighten it out manually tends to distort other vertices from other islands, so I’m at a loss for where I went wrong.

Blender file, with texture:
birdchair.blend (580 KB)

And thank you! Sorry for double-posting and giving you newbie post-approval headaches.

has been bookmark, this seems like a very interesting thread


One leg has UV vertices pinned so the won’t move when unwrapping again.

birdchair_ja12.blend (514 KB)