Uv mapping problem (proportions)

Using 2.44 I have a gun barrel, if i cut a edge down one side and cut edges for both ends so its just the outside of the barrel it does not unwrap correctly. It skews the unwrapping and this causes problems when im putting a image onto it.
I saw people talking about angle based uv mapping on 2.42 but i don’t see any options for this. How can i get my cylinder to unwrap correctly so it is rectangle shaped.
(even is i use pins and line up the corners it still is skewed in the middle.)

Something seems wrong here. I could go through and fix each face i unwrap but its not very accurate and is wasting me alot of time. Cube’s seem to work fine. Anyone know how to fix this issue or a plug in that works better. lscm is suppose to be really good for blender but i’m only running into more and more proportional issues the more i use it.

Any help will be appreciated. Thanks

Image added. This seems to happen with any cylinder with blender version going back to 2.42 i haven’t tested further back then that. I have checked normals and size and scale.

********************** Update 09/16/07
f for face mode
f9 for editing
uv calculation tab change angle to conformal (this fixes my wierd problem)
Never new about this tab / panel.


really quick answer: in the UV/Image Editor, box select the UV’s on the right hand side, Grab them and just move them down so your rectangles are square…err…your trapezoids become rectangles.

This is the way I have been fixing them. However you do realize on more complex objects this happens. Really this seems to be a bug in blender. I’m surprised no one has said anything before or fixed it.

Plus sometimes its not as easy as just grabbing one side and bringing it down. I wish there was a way of preserving the shapes and proportions of the quads/triangles. This would be much better for making quality uv maps.

It takes me a good 20-40 minutes to straighten out all the crooked shapes of a bit more complex object to get it half way decent for texturing. Just seems like it would be a simple fix, maybe not, I haven’t looked at the code.

I started using a good test texture and it helps get those more proportional however its still anyones best guess.

Thanks for the reply!!

There is. It’s called “Project from View” and it works the way you want if you select only the faces that are not distorted in the particular view you’re working from. So instead of spending 30 to 40 minutes straightening out UV maps in the UV Image Editor, you get to spend 30 to 40 minutes rotating the mesh and selecting appropriate faces. You could also try the new ‘smart projections’ and the UV Project modifier, but I suspect tweaking those to get unwrap to make a ‘perfect’ UV map will also require substantial tweaking.

Unfortunate fact of life, or projective geometry, is that flattening a 3D surface to 2D is going to involve some distortions. If shape and proportion are completely preserved, the faces would be connected by only a single edge, which would give you a shape that would be a nightmare to texture properly, except in simple cases such as your cylinder.

I don’t understand, you don’t think this is a bug? Unwrapping a simple cylinder in any other program wouldn’t give you these results.
That reminds me.
Does anyone know of a good uv unwrapping program besides blender. Also is there any other professional game artists using blenders uv unwrapping?
Where do i go to sumbit a bug? Does anyone besides me even care?
Thanks for the replies.

I dug a bit deeper. I submited a bug report. As well …

  1. it only happens on longer cylinders not short ones.
  2. if you knife your long cylinder to many shorter sections it will eventully fix it. shift + k (midpoints works good)(this of course is not good for my low poly budget but another workaround worth metioning.)
  3. Long squares didn’t seem to have this issue so it seems to be issues with more complex shapes.

I think if you unwrap your simple cylinder using smart unwrap you’ll get a series of rectangular faces, connected at the edge. If you unwrap it using a different algorithm you’ll get different results, depending on how the algorithm allocates the distortions. For anything other than a simple shape, the distortions are going to warp the two dimensional map of the three dimensional shape. It requires tweaking to adjust that 2D map to allocate the distortions to your liking, something that a software algorithm can’t know in advance.

So, you can try different algorithms, find one that more closely suits your preferences and your meshes and spend your time doing set up but only minor tweaking of the UV map, or you can use the default algorithm with little to no time spent on set up and spend more time tweaking the UV map.

If you visit forums for other CG software, and you’ll find everyone complaining about UV unwrapping. It’s the nature of the beast. Blender’s LCSM unwrapping was state of the art for a while, until the commercial developers ‘borrowed’ it to incorporate into their programs – a consequence of open source programming.

Anyway, there’s a place to submit bugs on the developers forum, which is on the Blender.org site. Good luck.

Even though i am working with low polygon numbers, So far it has been easier to use unwrap and pin certain corners then use the stretch tool with middle mouse button to align them up. smart projects would mean graping each face and stictching it back together in the shape you wanted. Depending on the model this could be a night mare.
I did submit a bug report and found it only happens on the longer shapes. I am not new to uv mapping or blender, its more of i have come across issuse when trying to develope for game that requires a higher level of quality then im used to. To get something that looks good in a game it all starts with the uv. Everyday I learn something new about the whole process and its good but sometimes these little road bumps cause lots of simple frustrations.
All it comes down to is if this gets fixed it will save lots of valuable time.

Thanks all.

********************** Update 09/16/07
f for face mode
f9 for editing
uv calculation tab change angle to conformal (this fixes my wierd problem)
Never new about this tab / panel.