Uv mapping

Ok, here is the problem. Im trying to uv map a mesh. But the faces are like, reversed.
ex. Im looking at the front of the barn but seeing the back texture couse the front is see throught. Looking at the back of the barn and seeing the front texture couse the back is see through.
I have always had this problem using uv textures and thats why i never used em. But now i have to couse im helping make a game and need to uv texture the meshes. So any sugestions on how to fix this would be great. Thanks!

hi pyro guy
I think you got to invert some of the normals.
Select faces that are messed up and click the flip normals.

Just check your normals, flip them if necessary. Also ensure the No V Normal Flip is on, in edit buttons, (not that it’s ever done anything for me, but there must be a reason for it).

Sweet! Thank you two soo much! I also just found and rememberd the option of double side for a face. So when i texture the face it puts it on both sides, so i dont get a clear side! Works great for these weird flap things. Thanks for the normal switch as well, worked great!