UV Maps same name, Still not joining correctly!

This has been bothering me for a few days now. I’ve searched everywhere.

  • All UV Maps are named the same
  • All normals are correct
  • I applied all transforms
  • Even deleted all uv maps, joined everything, then tried to texture everything again.

I always name my objects and materials.
The only thing I can think of I’ve done differently then usual is applied all Modifiers before joining.

It does show up in Cycles/Rendered fully textured. Is my machine just not good enough?

I havn’t had this issue before. I want to make sure its something Im doing wrong, as I don’t really want to go back to Blender 2.8 or lower

Intel-Core i5
NVIDIA GeForce GT 630
Blender 2.90

Still ‘new’ to the forum so I can’t upload the .blend file directly (Or add more then one image), but not sure if I can link it off site?

I’m not sure what exactly the problem is, could you clarify?

PS. Yes, you can link to an off-site hosting. Just please use one without obnoxious ads, etc. For files under 20 megs (IIRC) you can use e.g. the pasteall.org/blend/.


Me too facing same issues with GLtf file imported in blender it shows correctly in blender and online GLTF viewers but while importing to UE or
Google sceneforn tools it’s messing up UV maps.

Imported GLtf + seperate + textures format
Steps done are …same UV map naming for both objects.

Exporting not working either of formats like fbx,obj, all GLTF variants.

And Blender version tried are 2.91 and latest 2.92

my apologies! when joining objects the UV on all but one gets removed visually in everything but rendered.

Objects not joined yet

objects are already joined:

my uv maps are named the same though?

What does that mean? UVs are there in both files, they’re fine. Do you mean that somehow parts of the object after joining stop showing the image textures? You haven’t packed the texture images with the file, so it’s all just pink here, so I can’t really tell the difference between the two files.

ack, yeah thats what I meant, the image textures. I need to slow down and think about what I mean before replying!

I could’ve sworn I packed them, I must not have saved :confused: These are properly packed:

Not joined:


on the not joined, the image textures show up fine. But once joined, the images almost seem to be glitched out or completely invisible? Viewing in render seems fine, but I need to weight paint it and need it in solid mode D: Hope that makes better sense!

Huh, this is how the joined object looks here:

So the file is fine. Seeing as you’re using a GT 630, could be there’s some kind of graphics issue. Maybe you could try the 2.91.2 or 2.92, just to be sure?

I installed 2.92 and it works! How odd! Thank you so much :smiley: Solved!