[UV Packmaster] Efficient UV packing solution for Blender (C++ based, multithreaded)

add-ons
commercial

(abelwhite) #263

Hello, when i trying to enable addon (pro version, Blender 2.79, win10) i got error :

Traceback (most recent call last):
File “F:\distrb\blender-2.79.0-git.9f8bb58-windows64\2.79\scripts\modules\addon_utils.py”, line 331, in enable
mod = import(module_name)
File “C:\Users\user\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\uv_packmaster_init_.py”, line 9, in
from .operator import UvPackOperator, UvOverlapCheckOperator, UvMeasureAreaOperator, UvValidateOperator, UvSelectSimilarOperator
ImportError: cannot import name ‘UvPackOperator’


(glukoz) #264

Hello, I am not sure what could cause this error. Could you try removing the add-on completely and then installing it again?


(abelwhite) #265

Hello, tried remove and install 3 last versions, not helps, but also tried on my second pc and it is ok(also win10 home), i will search for reason why it happens at first pc


(abelwhite) #266

After reboot pc its enabled without errors, so all ok, dont know what it was, but sorry for take your time and thanks for great addon!


(glukoz) #267

No problem, good to hear that your issue was solved :slight_smile:


(cl) #268

Hi,

thank you for this great addon! I bought the Pro version a while ago and I am super happy.
Sadly today Windows 10 (after updating the virus definitions) marked the uvp.exe as a trojan (uv_packmaster-pro-1.91.2-blend2.8-beta). I am pretty sure it is just a false alarm but maybe more users are affected and I think you should know @glukoz.

Thanks for your work!


(glukoz) #269

Thank you for information.

I guess that some antivirus applications mark the add-on as trojan simply because they see that an executable file (containing the core of the algorithm) is called from a Python script being a part of a regular Blender plugin.
Off-course it is a false possitive as you said, I hope that antivirus software will get smarter in the future :slight_smile:


(CLuss) #270

Is the demo version as fast as the pro one for packing?
Thanks


(glukoz) #271

Yes, both versions, demo and pro, use exactly the same code for packing. The only difference is the demo version doesn’t apply the pack result to the UV map.


(Michael Knubben) #272

@glukoz
Could you allow the user to set Rotation Step to 180?
I often have to keep islands aligned a certain direction either for texturing- or shader-related reasons, and in the example I posted I’d want to keep them either pointing straight up or down, but no other rotation in between…


(Wanja Svasek) #273

So I got this addon, and am loving it so far, I have mayor issues when trying to pack to UV ratios other than 1/1 though.
That part seems broken, I would also love the ‘Pack to others’ to work with texture ratio.

I tried to pack with ‘Texture ratio’ turned on or off, but both methods will cause distortions.
It this feature not yet working for blender 2.8?

EDIT
Just tested in 2.79 and it behaves the same.
I loaded in a 2x1 texture and then proceed to packing the uv islands.
With ‘texture ratio’ turned on, it will scale the uv islands in the wrong axis, and will scale again and again every time I press pack.
With ‘texture ratio’ turned off some uv islands will remain intact, while others become distorted due to the ratio.
Not sure how to get this working right atm, help would be appreciated.


(glukoz) #274

@Michael_Knubben Sure, I will add such option in the next release.

@Wanja_Svasek The currect procedure for a non-squared packing is as follows:

  • unwrap islands on the sqared UV area so all islands have proper proportions in this area.
  • switch to non-squared texture in the UV editor, you will see islands will have incorrect proportions
  • pack using UVPackmaster with “Tex Ratio” option enabled.
  • packed islands should have proper proportions.

Let me know whether it solved the issue.

I have good news for you: UVPackmaster 2.0 will have non-squared packing worklow completely refactored. In particular it will support ‘Pack to Others’ :slight_smile:


(Wanja Svasek) #275

I will give that a go, and good to hear!


(Zagupi) #276

I’m having trouble with multi-object editing and the packmaster. Packing results are kinda exploded all over.
Blender version: Today’s latest 2.8-build. Everything works if I combine the objects into a single one. But I don’t want to do that in this workflow.
By the way, I’m impressed by the algorithm’s speed. Very nice.


(Fhq Group) #277

Mac OS 10.14…2
I keep getting error message about : “install OpenMP Library and restart blender”
and its already installed, i went on Brew.sh and fallowed them instruction, and the installation was successful.
on the product page the installation process was not so clear to me, it is an additional step i missed? any tutorial video on how to do that ?


(Fhq Group) #278

I’m having same problem, how did you got problem resolve ?


(kabu) #279

@FHQ_GROUP I followed the steps in the guide…
@glukoz instead now I get the following on installing 1.9.1:

EDIT: Mac Os 10.13.6


(glukoz) #280

@Zagupi I wasn’t able to reproduce this issue using the latest Blender 2.8 build. Does it happen with every multi object combination or only one specific? If only specific, then please consider sending us a blend file containing this mulit object combination. If you don’t want to share your work you can simply scale all 3D geometry to a single point. I would be really grateful.

@FHQ_GROUP [EDIT] From your post I can understand that you installed Homebrew. But have you also installed OpenMP itself? Note that after installing Homebrew you must also issue the command: “brew install libomp” in terminal in order to install OpenMP. Let me know whether it solved your issue.

@kabu Unfortunately I wasn’t able to reproduce this issue. I assume you are not using blend2.8-beta version of the add-on with Blender 2.79, right? If not, then as a first step please remove add-on completely in User Preferences and then reinstall it again.


(kabu) #281

My fault. There must be some addon which conflicts with yours. I’ve tried it in a clean installation, and it works. :rabbit:


(Zagupi) #282

@glukoz thanks, hey I may have found the cause. It happens if some of the objects in question are instances of each other.