UV protection not proportion

Hi! I select all face in edit mode and in Left View. Then I want to unwarp it with Protect from view. But the proportion on uvmap is almost twice as wide as the original. Please tell me how to solve this problem?

Very little information provided, therefore switching into wild guessing mode:
Is it possible that you scaled the mesh in question in Object mode and forgot to apply the scale afterwards (Ctrl-A > Scale)?

Are you choosing “project from view (bounds)” or “project from view”? If you choose the “bounds” option it will stretch the map to fit in the UV image editor pane (which is a square). “project from view” non-bounds version will give an unstretched UV, but you may need to scale it up or down to fit in the UV image editor pane.