UV - Smart Projections not straight

I’m trying to get Smart Projections to be perfect, using a simple cube but actually for complex interior meshes - so this means I can’t manually straighten them all out myself, so please don’t recommend that. I also need to use Smart UVs because normal UV methods screw up my lightmaps and ‘Lightmap’ UVs don’t like trapezoid quads for some weird reason…

Notice (for yourself) how the UVs are not perfect right-angles according to the mesh. I can’t possibly understand why this is? Where it gets these strange angles from? I’ve spent hours playing with different settings, from 2.49 up to 2.65a.

  • Is there an addon/script out there that can help me???
  • Maybe some method to snap the UV edge angles to 90 or 45 degrees???
    I’m desperate enough now to give anything a try!

Below is a pic and the absolutely necessary .blend files required for any reply.

cube_UVsmartproj_blends.zip (82.1 KB)


I agree it is annoying.

I can’t say for your complex mesh, but for the cube the workaround would be this one :

  • after you made the smart uv unwrap
  • in the uv editor select the whole uv then click on UV -> Seams from Island
  • in the 3D View click on U -> Unwrap
  • press F6 and play with the “Margin” setting

This will make the face as straight as desired.

Try then to see if it improves for your complex mesh

Thanks for your advice! I’m getting much cleaner results now with 99% of what I’m doing, but it’s still not perfect…

I have attached a very problematic (but simple) object here. If anyone knows Blender well enough to figure out what is going on with these wonky UVs and how to (automatically!) straighten them out (while still leaving the islands in big clumps like that) then I would really appreciate it, because I’m going bald over this lately…

xyz2.blend (441 KB)

For this specifically, i would do the following :

  • in 3D View select everything
  • top view
  • press U -> Project from View

Then if i need to separate each “lines”, in the UV/Image editor i would enable the following button , then enable Face selection :

And select manually each lined component and move them separately

It’s very possible something is not working right, i had my share of odd results in my various unwrapping.

The problem with complex models is that automatic solutions like Smart Unwrap are not always nice and can be a pain to work with when you’re creating the textures.
A good idea for complex models is to make “parts” , so you unwrap each part one at a time instead of trying to unwrap the whole thing at once.
It takes more time, but you have much more control on the resulting UV and it’s easier to work with such system.

Now for improving the tools, the problem is that the Blender Foundation has very few paid core (that dedicace all their time to Blender) devs and does not have the ressource to hire more people to work on core functions. That’s why many areas of Blender are not much developped yet (texture painting mode by example is rather bare bone and is lacking many usefull functions) .
There are help from many devs that are generously working for free on their spare time fortunately.

But it looks like the donation this year has been larger than before, and they may finally hire another core dev, so maybe we’ll see during the incoming year some more progress on those sectors that would surely use some updating.