UV stretching on flat face

I am having a problem with my UV unwrap relaxing the angles on this flat ‘face’ of my object, as you can see here, resulting in the texture being stretched along these edges.


The 3D view is on the left and the UV is on the right.

All of the faces on the UV island lie along the same plane, with no curvature, How do i prevent Blender from relaxing the angles on this UV island?

The ‘minimize stretch’ option in the UV menu does nothing to fix this. I’ve even tried isolating this into a smaller UV island, and I get the same problem, like Blender is hellbent on modifying my angles.

Always try changing the operator properties at the bottom of the toolshelf in the 3D View.
In this case changing the unwrap method to Conformal or setting ‘Fill Holes’ to False may help.

‘Project From View’ should also work if you want to unwrap a planar section.

And always upload a blend file to http://pasteall.org/blend/ and post the link, if you really want to get help.

Thank you for the help, using conformal mapping fixed the problem. I didn’t even see that option in the tool shelf because it disappears after doing a ctrl+p in the UV window. I should do another UV tutorial.