UV stretching on Sub-surfaces

The great UV wrapping mystery continues.

http://www.hdl.co.za/donn/face-select-mode.jpg
Pic1 shows my model in Face-select mode. Observe that the texture looks normal.

http://www.hdl.co.za/donn/normal-mode.jpg
Pic2 shows my model out of face mode.
See how the texture is stretching there?
This model is sub-surfaced on setting 1 or 2.

How do you cater for the extra stretching that sub-suraces will add to your UV settings?

Blend file here:
http://www.hdl.co.za/donn/UV_sub_surf_problem.blend

%|

Its because you had only one UV face selected in the 3d window. If you have all faces selected in face select mode (“a” key obviously) it doesn’t flicker between stretched and unstreched and then you can then adjust for the stretch in the UV editor. Why it does this is a mystery to me (it took me a long time to figure out the first time).

Hope this helps,
GreyBeard

Hi GB, I have tried all combinations of ‘a’ and ‘F’, to no avail.

Did you d/l the blend file?

The situation seems to be that in face-mode (potato?) the texture fits well because it’s uv-mapped to the more crude faces of the mesh.
When you then move out of ‘F’ view, you are seeing that mesh in it’s sub-surf appearance. Suddenly, there are areas of texture that stretch.

It’s as if the extra geometry of the sub-surf faces is too much for the more simple UV of the mesh that is used in Face mode.

I hope I have described the situ properly.

Yes I downloaded it, that how I could see what to do.

In the file as you gave it to me press f and then a twice in the 3d window. All faces are selected are now selected in face select mode. Press “f” in the 3d window – the distortion (due to subsurf) now doesn’t change. press “f” to go back into face select mode all faces still selected and also shown in the uv editor. Go into the uv editor and move the subsurf distorted verts to where you want them. Works here, just tried it again.

GreyBeard

Well, I don’t get it.

With all the faces selected, flipping in and out of ‘f’ still shows the distortion - it’s most prominent on the side of the head.

If you come out of ‘f’ mode and just toggle the “SubSurf” button on and off - you should see what I mean.

If not, then I give up. I have tried this on the official 2.34 and a newer CVS version.

I have put a short vid of what I see at:
http://www.hdl.co.za/donn/uv_issue.mpeg

You are right, I misunderstood and I apologise :expressionless: . To solve you’re problem though is pretty easy. Just duplicate (alt-d linked duplicate) your object and leave one in face select mode and the other in object mode. They will share the same uv mapping and you can see the effect of moving the uv coords on the subsurfed mesh without toggling in and out of face select mode. Adjusting the uv coords in the uv editor effects both meshes.
http://members.shaw.ca/rjplus/distort.jpg

Again sorry about the confusion.
GreyBeard

my solution to subsurf stretching ( i don’t know why it works ) is to, after setting the UV coords, duplicate, subsurf, and alt C >> convert subsurf to mesh, do your texturing, and then load the texture from the converted mesh onto the subsurfed one.

Hey GB - no need ! Thanks for the attention and the attempts! I couldn’t have made that video without your help!

Thanks for the replies - I will try both today. Gotta get offline now!

Question:
Why should the subsurf be stretching the textures at all? Is this natural, or should we be saying something on the dev forum?

GreyBeard:
I see what you mean, although I find it a little irksome to move the uv-coords; it seems so finiky and long-winded. I was dragging points around and watching the duplicate, it works, but it’s post-hoc really.
It has the advantage of keeping your mesh as a subsurf and that’s a big plus.

Modron:
I did not understand your reply. Without meaning to give offence, I find your replies a little too brief sometimes. Maybe you are a master of brevity, but I am not a good student! :slight_smile:

What I tried:
Mesh (A) (subsurfed) > dup > Mesh (B) (converted to mesh)
I put seams into A (cos it’s pretty easy as there are large edges to follow), LSCM unwrapped it.
I then duped and created B. Once again, I unwrapped it (LSCM) and this time, the “mesh” in the uv window looks much smoother, with a bunch more faces (as you would expect).
Suddenly, the texture distortion was gone!
Now, I had been using a test-map that I had painted according to the guides of mesh A, so I would have to re-paint another using mesh B’s guides (guides being a term I use for the unwrapped “mesh” in the uv window) - I have not done this yet, but I suspect it will look great.

Problem here is that the mesh is no longer a sub-surf and you have duplicates to manage.

I suppose there is a rule: Model first, uv texture last!


Does anyone know how that chap (Enrico Valenza) who has done those amazing dinosaurs in Blender? I would love to know how he got those textures wrapped onto those models! He has a tut about making the texture, but it falls horribly short of describing how he gets that texture onto his model. Those dinosaurs are the ultimate use of textures I have seen - besides @ndy, but he never explains how he does things!

Thanks for the help all!

quote:

Once again, I unwrapped it (LSCM)

sorry, I should have mentioned,…when you convert the subsurf to mesh, the duplicate retains the original unwrap,…just subdivides it. so you don’t have to remap. Your original unwrap will carry through to the duplicate.

try thinking it the other way round:
UV unwrapping is done to match the local topology of the mesh to something flat you can paint on. So the egdes of the unsubsurfed face coincide almost to a plane parallel to the UV plane, so the projection shows minimal stretching.
Now when the mesh is subsurfed the local topology of the mesh gets waves viewn from the UVW world. The higher that waves get the more stretching will occur, since the texture is still projected parallel from UV to the entire face. So as long as you don’t really subdivide the mesh all you can hope for is : tweak the UV-plane that way the waves don’t hurt too much.

BM

Ok - it seems that moving the uv’s around to ‘fix’ the stretching is the way to go.

I have found that unwrapping a converted-to-mesh-sub-surf takes too much toll on my machine!

I really think that someone who knows how to texture models like monsters and dinosaurs - complex models - should step up to the plate and do a UV tut about the whole process, even into and out of Gimp/Photoshop.

I am aiming to try that, but everytime I take one step forward I seem to take 5 back. It’s been a total mission so far.

Would someone post a render of the stretched UV vs. Non-stretched?

Not sure what you mean - there are two pics in my opening post and a video link of what I was talking about further down the page.