UV Texture Baking to Single Image Texture?

Hello, first topic.

I have had a good look around for this, but to no avail (including the two UV maps thread below this).

I am trying to create game assets (Unreal Engine, mobile device intended) and so naturally I really need to condense the textures down to save on space and memory.

I started by creating a pallet and texturing it. My process of texturing was selecting all the individual faces of the pallet on the “good” surfaces, and applying a “good” looking texture. I then moved the UV rectangles around to give each face a roughly different look. I then selected all the rough-cut ends of the pallet, selected those faces and gave a “bad” looking texture to them just to give a bit of change in colour.

However, the textures I used were 2000-5000 pixels wide and I only wanted a specific bit of the texture for my job. I decided not to UV map and export this for texturing in an external program because I figured this way would give me the most flexibility to change the texture later on if I wanted a different type of wood to be used.

So I am looking to create one texture (2048x2048 for example) which has both textures in it for the good cuts and the bad cuts and to have it as just one image.

I assumed texture baking would do this, but I am left with dramatic shadows across the texture. I just want the diffuse colour to show through.

I have attached an image to show what I mean. When I created the UV map, the rectangles seemed a lot cleaner and better positioned…

This is my first time getting this advanced in 3D stuff. I have tinkered with it before but never really created for a purpose. I’d like to not have to rebuild this entirely, but is there a way to recover or how am I best going about this given how I would like flexibility to change the textures later on to increase the number of variations?

Would using the paint tool and things like that allow me to produce even more variants (applying decals etc)?

Many thanks

Texture baking will do this. Ensure no overlapping UVs.

No blend files supplied
No indication of the renderer you are using
No indication of material settings
No indication of your baking settings

For your information, I am rendering through Cycles.

I have given it a go just baking “diffuse colour” but I am not able to produce one image with both materials combined in one.

I am getting the original input texture which is entirely black except in the areas where the texture shows, and it is being kept on two materials instead of combining. I have found it difficult to find a specific guide on doing this, so I have been grabbing bits of information from everywhere.

My method:

Select the pallet in object mode and tab in edit mode, hit Ctrl+N to calculate normals again
Go into object data and create a new UV map called “4KBaked”
Whilst selected, tap A to select all the edges/faces
Press U to create new UV unwrap
On UV editor, created a new image which is 4096x4096 and black with no alpha channel called “4KBakedTexture”
Average islands and pack the UV map onto this black image to fill the space
Go onto the object and create new material called “4KBaked”
Go onto the node editor for the material and add an unconnected texture node. I then select the “4KBakedTexture” image here but it leave the material unassigned to anything
Go into render tab
Set bake to “diffuse colour” and set the margin to 1px (I have left it as default as well, but less is better for me as it is a highly packed UV map)
Press bake and wait for results

The 4KBaked image does not update with anything as the bake goes on, it just remains black. I am then left with the original input files which are still massive (3000 wide or so) but effectively have the useful bits chopped out and everything else left black. I don’t have the two textures on my 4K image as desired.

Any ideas where I am going wrong?


I did a silly.

I got rid of a blank material and went into the node editor for my 2 existing materials. I created a blank “image texture” node in both and set it to the be 4k image blank image map.

I then went into the object data tab and clicked the camera icon next to my new UV map, which activated it.

I just need to work on cleaning up and scaling the UV map properly, but I have two materials in one new texture, so that’s all working!