UV Texture Mapping (simple)

I marked the seams of a cube and came up with a cross in the UV Editor.
I exported the cross as a .png and took it into an image editor and bucket painted a different color on each of the 6 faces (cube.png).

I clicked on the Textures tab in the main Properties panel. I clicked the new button and generated a new texture and set the type selector as “Image or Movie”
In the Image area, I clicked the Open button and selected cube.png.

In the main Properties panel I went to Mapping and set the Coordinates to UV.
I have a MacBook and thus a GLSL capable graphics card.
In the 3D window I set Viewport Shading to Textured.
In the properties Panel, under the Display tab, I put shading to GLSL.

What happens is that colors appear on only two of the six faces of the cube!
How can I get colors to appear on all six faces?
Thanks for your assistance. I’m using Blender 2.57a.

Hi - it looks to me like you have done everything right.

Usually, if you had no textures showing, I would say there was an issue with the method used to map, but to have them showing at all (e.g. even two faces) sounds like the texture is indeed applied.

Where I think the problem is, is that the default lamp is a simple point light, and it’s only illuminating two of the faces of your cube. Try going into Object mode and rotate the cube around (tap [R] twice so that the cube rotates in trackball mode). I’m thinking the other faces, which are very black when unlit may show their true colours once the face the light. You may need more of a lighting setup to do your full scene justice.

So - try that, and let’s know how it goes.

After this, there are variations of getting textures to work on different hardware. I find that if a computer does not support GLSL, then textures usually show up if “texture solid” is selected, usually with “Multitexture” ([N] key properties toolshelf) and this can itself depend on the 3D viewport shading option (“Textured” or “Solid”)… this makes getting the right “fix” inconsistent across different machines.

…but for now, it seems to me that GLSL is indeed working for you, so try rotating that cube.

Hi Lancer,

I rotated the cube by tapping R twice as you suggested above and it worked! Thanks very much for your prompt reply.
I am enjoying reading your book, Beginning Blender.

Thanks man, glad you’re liking the book. I’ve taken note to mention this point in the event of Beginning Blender reaching a second edition. It’s a simple enough thing, but could easily affect others who are working from the Blender default setup.