UV transparent glow

You can see that I managed to make the purple glow follow the bending of vertices by smart UV projecting it.

But here I perform the same method and yet it doesn’t work. Now matter if I connect Y or Z (from separate XYZ) to color ramp or play around with color ramp.

Ignore the z. UV are two dimensional, so it’s either x or y. As you did in the first example. Why it doesn’t work? Hard to tell without seeing the actual UV layout. How about importing from where it worked?

I did audio visualization on both of them, removed all the audio visualization settings and still it’s all the same.

Again, z doesn’t hold any data for ramp to work on for UV coords. Switch output to either x or y.
And I’m still not seeing the UV layout. Split the view and show the UV editor next to the 3d view.

I want the color coming from the bottom to top.

It’s smart UV project, the same way the other purple transparent object it.

Looks obvious to me that the UVs are oriented differently. Take a look at the original UVs and compare. It’s probably the “smart” of SmartUV project that is kicking in. I would add a seam, reset one quad and follow quads for the rest. Then turn on “about 2D cursor” and activate “constrain to image bounds”, select everything and scale so that it fits the space. This gives you a perfect UV space for math operations, but may not be suitable for painting on.

Cylinder projection from front view might also work, but you may have to reposition/scale the UV island.

If I add a cylinder with create UVs enabled (no caps), I also get a perfect UV layout for this purpose. No unwrapping required.

1 Like

Woah thanks alot fella. All I had to do is to unwrap UV’s in “project from view (bounds)” from front view.

Ok, good if it works. But it sounds like it might not work as good as you might think. From view projections will create overlapping UVs if the geometry is continuous (like a cylinder would be). From view is great for things like building facades, labels etc.