UV unwrap (project from view) is stretched - why?


I have a plane subdivided several times (see attache image).
Then I wanted to UV unwrap it, I choose ‘project from view’.
The faces of the mesh are squares as you can see but the UV unwrapped faces are stretched vertically. The other options of uwrapping produce worse results.
So I have to manually re-adjust the UV unwrap. If I have a bigger amount of objects tu UV unwrap this would be very time consuming. I thought ‘project from view’ will produce UV unwrapping like ‘what you see is what you get’, but it seems not. Why does Blender stretch this?
How can I get correct UV unwarrping of simple plane without manual adjustments?
By the way, the scale of the plane is already applied to 1,1,1.

Thanks for any help!

did you press project from view(bounds) instead

Hi PyroGXPilot,

yes I tried but this option stretches the faces to match the whole image size, which is not what I want. The aspect ratio fits than the image not the original mesh.

This is also happening to me, i hope we get a solution.

The answer if there is one would be in the file. Are you projecting from a perspective view?


there is no differenc if I UV unwrap from perspective or ortho view.
But I found out it is depending from the aspect ratio of the texture image.
So if aspect ratio of the image is 1:1 (squared) then UV unwrap seems to be OK.
But if the image has different aspect ratio the UV unwrapping follows this aspect ratio.

You can test easily if you UV unwrap a simple plane. Then if you switch the texture to different aspect ratio the UV anwrap changes to the aspect ratio of current texture image.

I don’t know if it is a bug or a feature!?!

Have you tried applying the scale? (CRTL + A, Scale)?

Hi spiderguy,

yes I did, I mentioned this already in my first post:

By the way, the scale of the plane is already applied to 1,1,1.

After unwrap there should be “correct aspect” option on the operator panel (bottom of the tool shelf or F6)

Grey UVs: project from view without correct aspect and
active UVs: project from view with

If that doesn’t work, you could try removing the image from the UV image editor, unwrap, then open the image again with the UVs visible (assigning face assigned textures again).

Hi JA12,

great, thanks that was what I was looking for!