UV unwrapping help

I am learning how to do UV texturing, and running into some difficulties. I have created a simple box with inset panels on the sides (I just extruded the sides inward), and now when I unwrap, my UVs don’t come out as expected. I constructed the mesh and created the seams so that it would be able to be unwrapped in a way that is perfectly flat. The problem is, when I unwrap (U > Unwrap), it does two things that I don’t understand.

  1. Although everything is set up at clean right angles, when I unwrap, the UVs come out with their proportions altered. Faces that are square in the model are slightly non-square in the UV.

  2. Relative size between the islands varies. Even though the mesh and seams are constructed in a very regular way, the islands come up in varying sizes.

I finally ended up having to fix all of this by taking an hour or so (I’m probably not as quick as I could be, but it still took a lot of work) to sort everything out. I had to export the UVs as SVG, then open in Illustrator so I could determine which of my faces was square, and use that one to check the squareness of all the other faces. I moved certain verts in the UVs to make them square again. Additionally, the squares for the pulled-in faces should fit exactly into the square holes on the outer edges, but they were scaled to be too large, and I had to scale them down. Also, the inset edge on every side of the cube is the same, yet they all came out different sizes in the UV unwrap - so I scaled them to be the proper size relative to the insert squares they wrap around in the mesh.



I want everything scaled in proportion so that they all get the same effective resolution in the map. I didn’t want the inset faces to be more high-res than the outside edges just because the unwrap scaled them bigger. Also, I didn’t want the inset edges to all be different resolutions because the UVs were all mismatched sizes.

Why doesn’t Blender do things proportionally by default on this sort of thing? I understand why rounded, organic shapes have all kinds of distortions, but for something flat like this, I don’t get it. Am I missing something? Is there a setting I should toggle, or am I fundamentally misunderstanding something?

Make sure you use Ctrl+A / scale on your object to clear any differences in the scale values for each axis before unwrapping. If each object axis has a different scale value you’ll get stretchoing of the unwrap.
For non organic objects its usually best to use the ‘conformal’ setting for the unwrap methon instead of the default ‘angle based’ You can change this by looking at the bottom of the toolshelf (T) when you press U to unwrap.
When unwrapped you can then also use Ctrl+A in the uv image editor to set ‘average islands scale’ (this is also in the UV menu). This will set the same scale for the different islands. You could also use Ctrl+P to pack the islands (also in the uv menu)


Thanks for your reply. In edit mode in the viewport, CTRL + A doesn’t do anything (I’m still learning the overall UI. Also, it may be worth mentioning I’m in 2.49b). CTRL + A does work the UV editor, and that seems to work to sort out the relative scaling. Selecting all my UVs in the UV window, then hitting CTRL + A, and CTRL + P seems to do a nice job of getting me most of the way there. I still seem to be getting some minor irregularities in the edges not being all perpendicular, though. Is there a quick shortcut to square everything? I have been using S + {AXIS} + 0 to line up verts and square things.

I hadn’t mentioned it, but I am using ‘conformal’ instead of ‘angle based’ already, after discovering that when I ran into a whole lot of non-perpendicular edges showing up on unwrap. While I still get a little, it’s far less than with the angle based setting.

Can you recommend a good tut anywhere that walks through this sort of thing in a comprehensive UV workflow explanation? Most things I’ve seen give enough info to get a particular tutorial model done, but don’t really dwell on the best practices of UV workflow.

Thanks for your reply. In edit mode in the viewport, CTRL + A doesn’t do anything
This need to be in object mode.

Can you recommend a good tut anywhere that walks through this sort of thing in a comprehensive UV workflow explanation?
Many uv unwrapping tutorials, both organic and non-organic objects http://www.blendercookie.com/category/all/tutorials/texturing/