UVs getting messed up when using subsurface modifier.

Hey guys!

Let me show you what is driving me crazy. Just finished unwrapping this simple model with nice results, but when i use the subsurface modifier my uvs get messed up! is there a workaround to fix this???

Any pro willing to help?

Thanks in advance



best is to subsurface your model before unwrapping, then, the unwrap takes into account the subsurf modifier automatically. i think you can also access the function in the properties panel.

Of course, the geometry changes with subdivision surface. Still, check that the object scale is uniform before unwrapping. Blender warns if it’s not but still, would be good to have the scale as 1,1,1. Ctrl+A -> scale to apply.

You could try unchecking subdivide UV’s from the subdivision modifier but that might not be the solution. Another way is to texture the modified UV’s. Might also need to add supporting edge loops or edge creases to keep the texture edges in place.

When you UV unwrap there is an option in the UV Unwrap operator panel to take into account the effect subsurf modifier. It is not enabled by default so do so.

Thank you guys! i Tried as you said to activate “use subsurfaces modifier” when unwrapping but that messed even more the rest of the uv’s (they were all waves), what it actually worked was what JA12 proposed, adding some edge loops that worked smoothly.

Thanks!!!