UVW doesn't work?!?!!!??

HI, I’m uv unwrapping an object, but when I paint, nothing shows up? :confused: I have 2.47. Is this a weird bug or am I doing something wrong? I am doing everything how I normally do it, but this still happens. Any help is welcome.

What do you paint where? You have to be a little bit more precise so that we can help you!

Some things to keep in mind:
You have to activate the paint mode on your texture in the Image Editor.
In order to see it in your model you have to have textured mode activated.
If you use vertex painting make sure you are in paint mode.
If you have your image outside in a different app you will have to open it in the ImageEditor to see it in the 3DView. To see it in the render you either have to use TexFace (only a good idea if you want to use the GE or do a 3d View render) or you have to map it to a texture channel of your object.

You can read up on texturing and painting here:
Texturing: http://wiki.blender.org/index.php/Manual/Textures
Painting: http://wiki.blender.org/index.php/Manual/Painting

I paint in the image editor, yes I have paint mode on and nothing shows up on the image, it stays plain black. And when I apply the image texture to the object, it still is black. This only started doing this last week. It worked before I downloaded 2.47 and I am still doing everything the same, but it doesn’t show up in the image editor or 3d view in shaded mode.

Can you paint directly on the Mesh, instead of the Image window? Do you have the “Enable painting…” button (little pencil icon) selected at the bottom of the UV window?

I dont know about painting on the mesh, haven’t tried. Yes, I have the pencil button selected. As I said, I’m doing everything the same as how I used to and it used to work perfectly.

I don’t know if it effects Texture paint, but have you check the Normals on your mesh to make sure they are facing out?

To let you know, I tested Texture paint in 2.46 and 2.47 and they work the same for me. I unwrapped the default cube, added a Black image in the UV window, went to Texture paint mode and painted away.

They were all facing out. Maybe I should check a tut to see if I’m doing it right? I’ll try again.

Post your blend and/or a screen shot of your screen as I can’t figure out what you are missing.
Did you actually unwrap your object (sometimes we miss the most obviouse steps) and is the correct uv layout displaying in the image editor when you go in edit mode and select all?

I’ve got a screenshot. As for your unwrapping question, yes, I did do that. Please don’t comment on the head.

You need to set the shading mode to textured to be able to see the strokes from the image on the 3d head. It’s the drop down next to the mode select box. Currently it is set tot solid.
I also do not see a brush on your image in the screenshot. But for testing purposes you might want to try to change the settings for opacity and size of the brush.

Nothing comes up at all. When I paint in the Image Editor, the image stays black, no matter what size or opacity I set for the brush.

Ok the following things strike me as odd in your screenshot but without having access to the blend (attach it to this thread) this is just guess work on my side and I’m currently unable to verify as I do not have blender on this machine.
You do not have a material assigned to your mesh (try adding one and see if that clears out the problem) and could it be that you have vertex paint active?

I don’t know if you misunderstand me or what, but my concern is not that the painting doesn’t show up in the 3d window, but it is that it has no effect on the actual image in the image editor. My problem is that when I paint the actual texture, it stays black. It is like the image editor is not responding to the painting I’m doing. The screenshot is taken after I attempted to paint in the image editor and as seen, the image is still black.

Can you post your Blend file? I setup a test that exactly matches your screen shot and it works fine for me in 2.47.

Here it is.

I opened your Blend Added a new image (you did not pack yours) in the UV image editor and painted on it. It works just fine for me.

Weird, because no image I try to do works. Maybe something with my computer?

I understood you perfectly but as I stated it is hard from your screen shot to see an error so I’m taking wild guesses here. So don’t get all worked up! Relax just trying to be helpful.
Anyway since you finally posted a blend I can open it perfectly well after creating a new image.
I attached my blend with the packed image see if you can open it and work with it.


GIRLFA.blend (392 KB)

Thanks, but it still doesn’t work for me? I still paint and nothing comes up, even on your blend file.?:confused:

What are you using for painting and can you give your video graphic cards and your system? Seems to be some sort of hardware problem.
Start blender with the debug flag (-d on the command line) and see if you get some output stating the problem on the console.

A few more guesses and suggestion what you can check:
If you are using a tablet try reinstalling its drivers.
If you are using a mouse and have special drivers try reinstalling them.