V-Ray Global Illumination Clouds

If i render an image with V-Ray i get some weird clouds on the surface of the objects. What causes that? How i can prevent that? I attached some settings and the render result.

Attachments




Does your window have a light portal? If not add it. (area lamp -> simple portal switch). This should fix you problem.

In case it doesn’t, or by any reason you need to avoid portals this stuff may help too, actually it’s wise to use it with portals too:
Irradiance map: Turn on “multipass”, “check samples visibility” and “detail enchancement”. If this wouldn’t help (but should) increase “interp samples”.

Light cache: Decrease(!) subdivs (1k should be enough for everyone). Turn on “adaptive sampling”, you may also “pre-filter” LC a bit (smooth gradients, but lack of certain subtitle details).

I used a sun lamp btw. Ok i tryed a area lamp as a simple portal. I attached the changed settings and the extremely bright render result. The clouds are gone but i have to increase the “interp samples” first up to 60. How i can reduce the brightness of this picture? Thanks for the tips!

Attachments




I sometimes get vray answers here. If you do not already know. http://vray.cgdo.ru/forum/index.php

I still have the problem of these clouds. I attached my settings and the render result. I hope anyone can help me again. I try pre-filter but if i use this i get very strong aliasing everywhere! I mean i bought v-ray and i have only problems with it. I thought it is a professional renderer :(.

Attachments




I’ve actually very little experience with vray but what i see looks very much like interpolation artifacts of the Global Illumination model.
If you’d used photon mapping i would have said you have too few photons or the final gathering settings aren’t high enough.
Try upping the samples or something like that.
Guessing from looking at the screenshots try increasing the sample size in the light cache panel. This should basically blur out your illumination without increasing the render time. I’m assuming that the parameter is something similar to Mental Ray’s Final Gather sample size parameter.

edit ehm irradiance map is something like photon mapping, isn’t it?

ehm irradiance map is something like photon mapping, isn’t it?

Don’t know, i don’t have much experience on V-Ray :(. Attached the new irradiance map settings and the render result. I still have these clouds, thats really annoying :(.

Attachments



No one? Any ideas?

It is, though it gives the best results to a professional user.
http://www.spot3d.com/vray/help/200R1/

Setting up the Light Cache and Irradiance Map is different for each scene; you will have to learn what the settings are and how changing them affects the final render.
http://www.spot3d.com/vray/help/200R1/examples_lightcache.htm

As for the brightness:
Either Turn on physical camera and tune exposure parameters, or play with colour mapping options (in your case I would choose: reinhard. Multy-0.8, burn: ~2 and more). Both and tonemapping of rendered image advised for better results.

As for spotches in second scene:
Increase light cache sample count but be aware that doubling sudvs paramets will quarter render time. So blur secondary GI via pre filter can be more useful. You can also decrease your Irradiance map max samples down to -1. There would be almost no visual difference but will render a bit faster. Subtitle ambient occlusion pass will deal with that quality loss on a composing stage.

What is you scene global scale? Physically it sholudn’t matter, but it actually does, if scene is too big or too small. Maya’s 1bu=1dm works for me.

Also
Small advise: avoid simple scenes if possible. Rich detail in geometry, complex shades and HQ textures will force render to increase attention at certain area and hide artefuckts in others.

Oh man. I tried to implement your advices but i still have this annoying problem. Why is V-Ray so extrem hard to handle? Attached settings and render result. And what is this weird looking streak in the center of the Picture? Looks like a shading error, but i corrected the normals and removed doubles. So what is that? I also have that problem on another scene. I also scaled the scene strongly down.

Attachments




I think your HSph. subdivision are a bit low and the interpolation sample too high in the Irradiance Map.

Try 100 for the HSph and 20 for the Interp. samples. Plus the min max rate should be -3 and 0 for better quality (but more time needed)

Cheers

edit: i wrote light cache instead of Irradiance Map sorry

Still there. I increased the HSph to 100 and put the Interp. Samples to 20. I also corrected the min - max rate to -3 and 0. And from where comes these black marked line?

Attachments


Is the lighting all outside the room?

Show a screenshot of the lighting setup (Posting up the file would be better).

I hope you can understand my light-setup. So yes, all the light is outside the room.

Attachments



Move the area light close to the window, and scale it so that it just covers the opening, then work through this:-
http://www.spot3d.com/vray/help/200R1/tutorials_interior.htm

I tried to follow the steps but most of these options i doesn’t have (such as “Light map”, Global subdivs. multiplier,…).

DMC-Sampler

Instead of “Global subdivs. multiplier” i put the “Subdivs mult.” under “DMC sampler” up to 16. I also set the “noise threshold” to 0.002 and the “Min samples” to 16.

Irradiance Map:

Preset: Medium

HSph. subdivs: 8
Interp. samples: 5
Multipass, Randomize and Check sample are checked
Detail enhancment unchecked
Calc phase and Direct light are checked
Samples are unchecked
Use camera path is unchecked

Light Cache:

Subdivs: 500
Sample Size: 0.02
Store direct light, adaptive sampling, show calc phase and Auto num. passes are checked
Filter is checked, Pre-filter ist unchecked

If i start to render the estimate time to produce the light cache is 30 minutes!!! The final image of the tutorial rendered only 4m and 12.7s! I am quite angry now. Nothing is working with this **** piece of software :mad:. Thanks for the friendly help. Still any tips?

You can’t assume the same render time for a different scene with different lighting on a different pc rendering to a different size.

Expertise with a render engine requires experience, and to get the best from the software you need to understand how it works. I suggest you take a step back, relax, do some V-Ray lighting and rendering tutorials and come back to it later.

Vray is one of the best and most advanced render engines available to the public, that said it is also hard to master.

You can’t just expect to press a button and get a perfect render, it doesn’t work like that, you actually have to learn to use the settings correctly yourself if you want to produce amazing renders.

As organic said the render times depends on what settings you are using, what system resources you have and how high a resolution you are trying to render.

Don’t blame the software for your own inexperience, read the Vray manual, watch tutorials for setting up lights and render settings (watch non-blender tutorials as well, a tutorial for using Vray/3ds Max works for Vray/Blender as well) and try the different techniques on different scenes. When I started learning Brazil for Max I sat down for over 5 hours just trying out different settings, what parameters affected render times and which ones produced better quality with different lighting situations and render algorithms.

You just have to get used to it and then the rest will flow on.

But at no tutorial is these problem described. I have watched every v-ray tutorial on youtube. Maybe it’s my fault, yes.