Various issues with Video Sequence Editor and previewing/scrubbing clips.

I use Blender strictly as a Video Editor. Here is my system information:

Radeon Software Version - 16.9.1
Graphics Chipset - AMD Radeon ™ R9 Fury Series
Windows Version - Windows 10 (64 bit)
System Memory - 32 GB
CPU Type - Intel® Core™ i7-5930K CPU @ 3.50GHz
Blender version - 2.78 (Date 2016-09-26)

The problems: The two issues I have are that previews are painfully slow, and they don’t accurately reflect what part of a clip I’m on when they aren’t slow.

Specifics on slow/low FPS during preview: I have a single 2.67GB clip that was recorded with Open Broadcaster Software Studio which is 1440p at 30 FPS. This clip is around 9-10 minutes long so the bit rate is relatively high. While playing back the clip during editing with AV sync on, the clip’s preview FPS ranges from 1-5ish. Sound plays fine. My CPU is in the 90% range. OpenGL rendering options are all off (no anti-aliasing, or full sampling).

With AV sync off (no other sync is on), the FPS is 30 and it plays fine aside from slight desync in audio-video. I’ve tried setting the Proxy Rendering to 25%, but that hasn’t changed anything.

This doesn’t seem right. It doesn’t make sense to me why my system would be choking on this.

Specifics on preview inaccurately showing frames: I wish to turn AV sync on, because I have what might be a separate issue where moving a clip after cutting it seems to change where it was cut. What I mean is, if I hard cut a single clip (press Shift + K) at frames 100 & 500 (creating three clips, one for frames 1-100, one for frames 101-499, and one for frames 500+) and erase (press X) the middle clip (frames 101-499), then move the 500+ frame clip to a separate track so that it can easily transition from the 1-100 frame clip, the 500+ frame clip plays as if it starts at frame 101 of the original clip. I’m hard cutting it, so as far as I know, it shouldn’t be doing that.

What I’ve checked so far:

User Preferences > Input > Sequencer > Cut (soft) and Cut (hard), they are the correct K & Shift + K commands respectively.

User Preferences > System > Compute Device, it is set to OpenCL > Fiji (My Fury X GPU). Based on Radeon Settings, my GPU isn’t being used at all. Neither during preview or during animation rendering.

User Preferences > System > Sequence/Clip Editor > Memory Cache Limit is set to 10240 (10GB) as I have plenty of RAM. However, letting the preview play to put it in cache doesn’t help playback. The clip I’m using is on a PCI-e SSD, so storage transfer speeds aren’t the issue.

I really just don’t know where to begin with this. It’s like blender is broken but I’m not sure how I would’ve managed that.

Edit: I did find this: http://blender.stackexchange.com/questions/40347/movie-editing-low-fps-on-preview

A friend suggested me the solution.

The problem was the FILE CODEC.

Smartphones often use H264 codec that are awful to decode on the fly, so preview will hang even with a decent hw. Ironically, a 100 Mb video file from a smartphone (LG G3 in my case) can be heavier to decode on the fly than a 1 Gb file encoded with Xvid (wich probably isn’t the best option for a video edit, but at least prevents sluggishness).

Could that really be my problem? These clips are indeed encoded using H.264.