VCOMP90.DLL HUGE Save Runtime Problem Here

This is the errors:

.exe - Unable To Locate Component

This application has failed to start because VCOMP90.DLL was not found. Re-installing the application may fix this problem.

Now, when I first tried to build the exe file by going to File>Save Game As Runtime , I used the directions at this link:
http://wiki.blender.org/index.php/BSoD/Introduction_to_the_Game_Engine/Creating_more_complex_game_levels_and_interactions#Making_a_stand-alone_version_of_the_game

When I asked some people about the problem, they referred me to this document:
http://en.wikibooks.org/wiki/Blender_3D:_Noob_to_Pro/Making_exe

Guess what? I followed them to the letter, and they did not resolve the error. Then, someone recommended that I install Microsoft Visual C++ Runtime Environment or something, here:
http://www.microsoft.com/downloads/thankyou.aspx?familyId=9b2da534-3e03-4391-8a4d-074b9f2bc1bf&displayLang=en

Well, my first thought was: “Why should I have to ask anyone who wants to play my game to install this program? I don’t even want it on my computer!”

Anyway, I installed the program that I didn’t want, and the .exe file returned the same error. Couldn’t find VCOMP90.DLL on my computer anywhere, so I downloaded it from vista-dll.com:
http://www.dll-vista.com/liste.php?lang=en

Couldn’t this be included in the package? I lost over an hour on this and installed a crap program that I really don’t want.

:eek:

Hello
all those nice dll files are “microthing” propriety…if you include them in a package you probably end with 45 lawyers in “your back”?!
With my Debian/GNU/Linux system, I never had those kind of messages since many years ( nor blue screens).
Bye

And you don’t see how retarded that is? I can’t distribute a game for Windows machines without including a .dll file that ends with “45 lawyers” in my back? That’s why I say this is a huge freegin problem. Blender GE should be able to release a stand-alone runtime, and it should be able to release to any OS. Congradulations on having an OS that supports releases from Blender GE. When you want to give it to your friends who use Windows machines, what OS you’re on doesn’t mean spit. You’re in just as much of a situation as I am.

:spin:
Any fixes?

Well…I should “update/upgrade” my Debian system sometimes…probably windows users should do the same?
By the way, I never heard of this “vcomp” problem before?!

why dont you build blender with mingw? it doesnt need those libs

Yeah, everyone should just install Debian.
I’ve seen the vcomp question go unanswered at a few forums, not this one though.

I’ve never heard of mingw. I got a fresh install of Blender 2.48 from blender.org that came with this problem. The two tutorials I’ve been through on blender.org and blenderwiki didn’t say anything about mingw or how to build it, so I naturally didn’t do that.

I found some information on another forum which suggests that the particular dll can be included with your games/packages which I thought I would share as I have just hit the same problem as you with a fresh blender 2.48 download

http://social.msdn.microsoft.com/Forums/en-US/vclanguage/thread/39065e70-2ca0-4d63-bcb3-ab8acf949f84/

Hope it helps

Yes. Through my experience of the error, the best thing to do is download the required dll’s and any other missing one and just include them in the package that you send to the person you wish to play it. :yes: Then it will all work out.

vcomp90.dll is apparently part of their “redistributable” package, so you won’t get any lawyers on your back for redistributing it.

Hello
all those nice dll files are “microthing” propriety…if you include them in a package you probably end with 45 lawyers in “your back”?!

Yea, alway rumors that say “I think you legally can” or “I think you legally cannot”
bug me since a while. I’m pretty sure we can sell a blender game without much
problem, but I ain’t having any strong documents to prove that.

Blendenzo could probably tell more,
but it would be cool to know 100 % sure if we can or can’t sell
a game made with blender that peoples could just “launch” without having to
install blender, python and 5613-55 mores applications.

All the MSCV files, actually, are redistributable files, so:

  • They should be included with the application ( if you download Blender 2.49b it will have those in fact, and its not illegal ), as Microsoft said, these are user end dlls so they should be included by the maker of the application

  • Better of all, you should keep your system up-to-date, since the .Net Framework is used by A LOT of applications on the Windows systems, so installing the latest Microsoft .NET Redistributable Framework will do the trick…

So, this is not a “crap program I don’t want to install” but some “dependancies I need to install if I want the latest applications to work on my neat system”

Cya =)

EDIT: Wtf, this thread is one year old people!? Why resurrect it ffs

I’m glad I’m not the only one with this problem. I found a vcomp90.dll, but it’s either the wrong one, or vista64 just doesn’t recognize vcomp90.dll, although it’s still asking for it when I try to run the basic game from the tutorial.

Even starting a brand new file, saving that as runtime requires all the other dlls that are not included with blender, and even then windows will still ask for vcomp90.dll once it does compile.

Do you have Blender for the 64 bit version of Vista?

yeah, that’s the one. I specifically looked for the version of blender that was made for Vista 64. I’ll link to it here.

http://download.blender.org/release/Blender2.49b/blender-2.49b-win64-python26.zip

Then that’s and error from the part who compiled the version, since Microsoft states that when you compile an executable you have to include the .NET Runtime dependancies or at least a reference to where to download the Redistibutable Package ( available from Microsoft )

So in this case you have to remedy by yourself and udpate your system :slight_smile: ( I think there is a 64 bit version of the redistributable package, after installing it you can grab the dlls from your system directory and place a copy of each in the blender directory so you can easily distribute your files without repeating the error of the blender compiler :slight_smile: )

Cya =)

I’m not the one who compiled it, though. It’s a .zip file that contains the executable. The additional link on the page lets you install the MS Visual C++ redistributable package, which I did, and the game compiles properly, and copies the dlls it needs, but whatever the problem is with vcomp90.dll keeps the game from starting up. I have one copy in my blender directory, one copy in my syswow64 directory, one copy in my system32 directory, and one copy in the game’s directory, and starting up the game causes the error that “VCOMP90.dll wasn’t found.” Meanwhile, using the
c:/windows/syswow64/regsvr32.exe vcomp90.dll
command still comes up with the error:
The module vcomp90.dll was loaded but the entry-point DllRegisterServer was not found.

It seems the easiest solution for now, is to download the 32-bit windows installer of blender, since it checks for and copies all necessary dlls while installing. After starting up that version, saving the project as runtime, going to the game’s directory, and running it in windows, it ran perfectly fine, even in Vista64.

They need to fix their 64-bit windows build of blender, and/or Microsoft needs to get their vcomp90 to load properly into windows.

Um, its a strange problem indeed, though I think its more probable the problem comes from Blender, so the best solution now is using the 32 bit version, you are right :slight_smile: