Vect Blur, does it work with lights?

I can’t make my spot light sadow blur as it moves (I have exagerated the movement) and even the box that does blur as it moves won’t cast a blurred shadow? How can I get it to work or won’t it ever?

Are you sure you’ve got all the settings right… e.g. “Do Composite” set in the Render buttons and “Use Nodes” in the Composite window?

I’ve tried it out… seems to work for me.

Here’s an example of vector blur(first image) and motion blur (just for comparison sake!):


vector blur will do nothing for shadows of moving objects

Yes z3r0 d that seems to be the case, I think that narnia’s 1st image shows blur opn the base plane because ‘it’ is moving, not the just the box above.
I find this to be a major problem with the function are there any workarounds?

Vector blur has no effect on either shadows OR reflections.

Aha! I now see what you mean now. I thought you were talking about the fact that the shadow didn’t blur when the camera was moving, not the objects! Silly me!

Anyway I tried using Motion Blur and the shadow blurs perfectly, so this would be a slow workaround for you.

I’ve tried working out a solution with the nodes compositor, but I can’t think of one at the moment.

The problem is that Vector Blur is takes it’s information based on the position of vertices or something like that, so it obviously wouldn’t take the shadow’s information into account (see

Wouldn’t it be possible if you tried doing a Radiosity solution and converting to a mesh? I’m not really sure how this works, so I can’t try it out…

There is no way to get around some of the limitations of vector blur as an end user. what i do when i need good looking motion blur, is enable 5x motion blur and then setup a vector blur node, this will significantly reduce the ghosting effect of motion blur and the some of the inconsistancy of the vector blur.