Vector blur on deforming objects

Hi, I’m in cycles and try to use vector blur since my model is to heavy to be rendered with true motion blur. And for some reason my beast model controlled by an armature recieves much less blur than its teeth. I guess it’s because the teeth and aren’t deformed by an armature but have “true” motion. But I have no idea of what to do about it.
Here is a comparsion between with and without vector blur:

Could you add a .blend file? It’s hard to tell what might be the problem. Are the teeth parented to the armature?

Sorry for late reply. The teeth are vartex parented to the mouth so they move as the model deform.

OK, I know it has been quite a while since but I still haven’t found why this occurs…
Here is the blend:
Can someone take a look?

YESSSS!!! I’ve finally localised the problem, it’s because of the “Auto smooth” option… when it’s turned on the object doesn’t recieve any motion blur what so ever… wieeeeerd…

I guess I can work around this using two render layers: one with my object auto smoothed and the second without. Then I use the second’s “correct” vector pass for the vector blur.
I think this should work, but if anyone know a better way - like having motion blur despite Autom smooth - I would be very happy to know :slight_smile:

At least I’ve found the problem.