Vector Mapping value problem?

I want to control the Mapping Location so created some values to be used with Combine XYZ but even the values seem right it’s not right when connected? …
Screenshot 2021-01-10 193148

Do you mean that the vector out of Combine XYZ doesn’t connect to Mapping’s Location?

EDIT Again As Amicus1 noted I had totally misread the question and this answer is for rotation not location :frowning: I thought that I would leave it anyway as it is still interesting.

Here is my wrong answer!
internally blender does not think in euler angles. You have to enter the values in radians. The math is complicated and I do not totally understand it myself.
Here is a screen shot of a converter I found that gives the correct values, unfortunately it did not let me enter the degrees with decimals so I used 26º and 10º.


If I use those values in the combine x,y,z node it does rotate as you expect

I did not plug the node in so you can see the 26º, 10º values but if you plug it in you will see the rotation is OK.

Edit: after a second try I did get the converter to work with decimals, I had to enter the degrees with a coma not a dot (26,4 10,8)

Edit 2: the link to the converter:

The question was location…

1 Like

Sorry I misread :frowning:
Edit I just checked with location in the same file I was using and the values worked normally (26.4 10.8 in combine did the same as in the mapping node)

Thanks for the replies. Yes Location, Rotation & Scale work fine.

Look at the inches indicator on your mapping node’s location values, which isn’t on your combineXYZ values. I’d suspect it is has something to do with custom units that you’ve set up. Not that Blender’s actions here make much sense. I guess units might make sense with generated coordinates or object coordinates, but they’re never going to make any sense in terms of UV.

Additionally, it probably doesn’t make any sense to be shifting UV by values greater than 1.0…

I see, so the value of the Combine node will range the UV space from 0 to 1 but the Location displayed is referring to the Scene Units, if Unit System is None I get 0 to 1. Trouble is I need the Unit System set.

You can use the custom units, you just have to do a conversion on them. (I should restate that: you should be able to use them, but I don’t know much about them, because I never use them myself.) I would suspect that Blender is doing the same conversion it would do to convert them to world-space “Blender units” in the mapping node. For instance, if your starting cube is 1m tall, then it’s probably dividing your inches by 39.3701 to arrive at the actual mapping value it uses. You should be able to stick a vector math node in between the combineXYZ and the mapping node to use the combineXYZ as inches.

Ok thanks.

1 Like

If using a procedural texture like a wave texture values over 1 give different results, 0.1 does not give the same result as 1.1
With an image texture it does give the same result, but if you want to animate the texture location it could be useful to use values over 1