Vehicle wrapper glitching through floor

Hey guys!

It’s been a while now since my thread, but now I am back with a new problem :slight_smile:

So in my game I have a small powerful car controlled by the vehicle wrapper, everything works as it is expected to except the big problem that my tires are always glitching through the floor after a jump, a wheele or even after I brake.
(See the image below)

So does anyone now a way to avoid this problem, anything?

Thanks in advance!!!

Attachments


It’s been a while since I had this problem and I don’t know anymore what’s causing it. I’m not sure but I think it has something to do with the Physics properties. Did you set the wheels to No Collision and do you have Compound disabled on the vehicle? Did you set the Collision Bounds to Convex Hull with a minimum Margin of approximately 0.05? Has the floor also a minimum Margin of approximately 0.05 and did you set Collision Bounds to Triangle Mesh? Or maybe the problem is that the origin of the vehicle is not at the bottom of the mesh?

I dont know why this is happening, but I found a workaround for it: You can create a physics mesh that ensures a ground clearance smaller than the suspension way.
Not really pratical but it works for now.

Cough cough, 6dof vehicles Cough

Until now I haven’t seen a good alternative to the vehicle wrapper. I’ve looked at the demos (of you and others) but they are incomplete to such degree I even wonder if 6dof could do it. I’m still curious to find something that has all the features of the vehicle wrapper without the bugs. So keep me posted (better in a different thread) if you find something that could be what I’m looking for.

Through various experiments I found that this is (normally) caused by the suspension offset(wheel position) on the z-axis. Try setting the z axis to 0.

[EDIT]
This might mean that you need to offset the center of your “chassis” object to keep the wheels at your desired height.

Maybe post the blend file?
Just incase you wont be able to post the blend,
-Maybe you have not applied the scale. (select all > Ctrl + A> Scale)
-Also try not to use triangle mesh where high velocity collisions are going to take place… Try using convex hull or if possible the primitive bounds.
-Last what I can suggest is to remove the gravity of the world and handle gravity on your own… so that you can turn it off if the car is in contact with the ground…

Again, id suggest to post the blend file…