Vertecies not moving although weight painted and parented to amature

got blender 5 days ago. It’s fun.

Anyway I just rigged my first character parented an amature to it. The weight paint is applied and
ALMOST the whole character can be moved by it now.

There are some verticies in both of the ears of my character wich just won’t move. They are not asigned to another bone wich could make them stuck at those locations. I spend avlot of time trying to figure out what’s wrong with that. Should be some tiny detail I am missing here.

Please help me

The Bones of the ears of my character are called Ohr.L und Ohr.R



The file:

Thank you in advance

They are assigned to another bone.

Look at those weights-- -2.836 to kl Finger 1.R. I didn’t even know you could have negative weights!

Running a clean operation on all verts (weights/clean from weight paint) will fix it.

But there has got to be a bug in here somewhere. While it might be interesting to have weights outside of 0,1, I’m pretty sure Blender hasn’t decided to start doing that for you. There must have been some bugged tool that got those weights for you.

I made it work!

Thank you for your quick reply bandages. Appreciate it. I got two questions.

**1.**I checked if those stuck vertecies are assigned to another bone as I did before starting this thread.

Please have a look at this:


I’m wondering if you are right because I also moved all bones at once and they are still stuck as seen in the picture. So they have to be stuck because of another reason? Anyway I solved it another way. (look at the end of this post)

I am also wondering like you, how it is possible to have negative weight properties and how I managed to do that. Maybe someone else reading this post knows? I will check the forum for this issue.
Anywaythank you for pointing that out

2. How can I display the weight properties as seen in the image you postet? Is it an in-built function or did you use this addon?

I just see this post is from 2012 so I think it is built in properly by now

My solution

Fortunately (in prediction of me messing things up) I saved a double of my charcter object in another scene wich was still existing in it’s loose parts and was not rigged or weight painted at all.

Now I seperated my current character object by loose parts again. I deleted the ears of my current character object and put in a pair of ears of the one I saved earlier in another scene. Then I merged them with my rigged character object, weight painted them again and now it works properly.

You can check your weights via the property shelf, which I access via ‘n’ key, with an active vertex selection (so in edit or weight paint mode.) No add-on is necessary.

Thanks a lot.