Vertex Group won't sync with bones?

I build the armature following a tutorial. I used Parent > Amature Deform > Empty Groups to create Vertex Groups matching the bones and manually assigned each of them. But the Hip and Part of the leg arent posable, as you can see in the picture attached. I realised that the list of vertex groups was missing the hips, leg.R and leg.L, so I created them afterwards, giving them the same name as the bones but they won’t sync.

Can anybody help?

Things I tried so far:

  • repainting the Weight in Edit mode of he mesh
  • unparent and reparent the armature wih the mesh
  • renaming the vertex groups
  • restarting Blender
  • deleting the selfmade vertex goups, unparent and parent again with create empty groups (nothing changed, it still didn’t created vertex group fo the leg/hips by itself)
  • since I use a duplicated mesh with “copy transformations” I also tried to give them the name of the duplicated bone (TGT leg.L instead of DEF leg.L)

nothing worked and the internet just tells me to use exaclty the same names…
If anbody knows what I missed or did wrong please help!
thank you very much <3

This is the part that should follow the bone

You have to make sure that the new bones have “deform” checked

I knew it was a simple solution and I was just dumb and shortsighted… thank you so much