Vertex groups disappear after Append from 3.0 to 2.83?

Hello,
I rigged a basic character while just parenting the non complex parts and rigging with automatic weights and empty groups (for manual weight paint) the complex ones (legs & arms).

Now when i Append the animated character to a previous version of Blender (2.83) the arms and legs are not parented to anything and their vertex groups disappeared.

The Append from 3.0.0 to another 3.0.0 scene work well but i need him in 2.83. Is that a new bug to report ?

3.0 recently changed where vertex groups live : in mesh rather than object. I would think this is related, but to make sure I’ll take the liberty to ping @HooglyBoogly if you don’t mind

Cheers,

Hadrien

1 Like

Opening in a previous version isn’t considered a bug. See:
https://developer.blender.org/T90746

I am not certain about the appending case though. You can export using a format that saves vertex groups, and reimport as a workaround.

1 Like

Not a bug, you’re talking about backwards compatibility, which we already know isn’t there from 2.9+ backwards. IIRC there’s even a warning if you open a new file in 2.83

1 Like

Thanks all for your answers
I should have inquired about that before tried a project in 3.0.
So now have I a way to get back my vertex in a lower version ? Or is it recreating the rig the only solution?
I tried exporting it in fbx, dae, collada, gltf… there’s always one part of the export that is screwed

You can make a list of all vertex weights, their names… and read it back from 2.8

I don’t get it. Does it mean i have to do this for each vertex separatly ?

No of course not, I meant from Python

I haven’t done this before, but it’s definitely possible and shouldn’t be very difficult. I don’t have time to work on it for you unfortunately. Here is the API doc : https://docs.blender.org/api/current/index.html#

1 Like

Thanks you !